aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-optim/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave-forge-optim/Makefile')
-rw-r--r--math/octave-forge-optim/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/math/octave-forge-optim/Makefile b/math/octave-forge-optim/Makefile
index c2e7edbecd70..d0c71d8a867d 100644
--- a/math/octave-forge-optim/Makefile
+++ b/math/octave-forge-optim/Makefile
@@ -12,7 +12,11 @@ CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
RUN_DEPENDS+= ${TARBALLS_DIR}/miscellaneous.tar.gz:${PORTSDIR}/math/octave-forge-miscellaneous
RUN_DEPENDS+= ${TARBALLS_DIR}/struct.tar.gz:${PORTSDIR}/math/octave-forge-struct
@@ -21,6 +25,6 @@ RUN_DEPENDS+= ${TARBALLS_DIR}/struct.tar.gz:${PORTSDIR}/math/octave-forge-struct
.include "${PORTSDIR}/Mk/bsd.octave.mk"
post-build:
${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${DISTNAME}
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
.include <bsd.port.post.mk>