aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-plot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave-forge-plot/Makefile')
-rw-r--r--math/octave-forge-plot/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/math/octave-forge-plot/Makefile b/math/octave-forge-plot/Makefile
index 791bdecefab2..f79f28e1b55a 100644
--- a/math/octave-forge-plot/Makefile
+++ b/math/octave-forge-plot/Makefile
@@ -12,6 +12,10 @@ CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${OCTAVE_PKGNAME}
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/Mk/bsd.octave.mk"
do-build:
@@ -19,6 +23,6 @@ do-build:
post-build:
${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTAVE_PKGNAME}
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
.include <bsd.port.post.mk>