aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-specfun/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave-forge-specfun/Makefile')
-rw-r--r--math/octave-forge-specfun/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/math/octave-forge-specfun/Makefile b/math/octave-forge-specfun/Makefile
index 119a64df59c4..4801f955be9e 100644
--- a/math/octave-forge-specfun/Makefile
+++ b/math/octave-forge-specfun/Makefile
@@ -13,12 +13,16 @@ CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/Mk/bsd.octave.mk"
post-build:
${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${DISTNAME}
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
.include <bsd.port.post.mk>