aboutsummaryrefslogtreecommitdiff
path: root/math/octave/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave/Makefile')
-rw-r--r--math/octave/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 1bfff00e8843..236df6c49382 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= octave
-PORTVERSION= 2.1.30
+PORTVERSION= 2.1.39
CATEGORIES= math
MASTER_SITES= ftp://ftp.che.wisc.edu/pub/octave/bleeding-edge/ \
ftp://ftp.eos.hokudai.ac.jp/pub/GNU/misc/octave/bleeding-edge/
@@ -16,6 +16,7 @@ MAINTAINER= chuckr@FreeBSD.org
USE_BZIP2= yes
BUILD_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
+LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw
.include <bsd.port.pre.mk>
@@ -29,7 +30,7 @@ PLIST_SUB= OCTAVE_VERSION=${OCTAVE_VERSION} GNU_HOST=${GNU_HOST}
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-shared --host=${GNU_HOST}
+CONFIGURE_ARGS= --disable-shared --with-fftw --host=${GNU_HOST}
.if ${OSVERSION} < 400004
CONFIGURE_ARGS+= --with-f2c