aboutsummaryrefslogtreecommitdiff
path: root/math/onednn/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'math/onednn/files/patch-CMakeLists.txt')
-rw-r--r--math/onednn/files/patch-CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/math/onednn/files/patch-CMakeLists.txt b/math/onednn/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..1c0e6c8163ed
--- /dev/null
+++ b/math/onednn/files/patch-CMakeLists.txt
@@ -0,0 +1,28 @@
+--- CMakeLists.txt.orig 2020-03-31 16:33:27 UTC
++++ CMakeLists.txt
+@@ -92,7 +92,9 @@ include("cmake/mkldnn_compat.cmake")
+
+ include("cmake/utils.cmake")
+ include("cmake/options.cmake")
+-include("cmake/OpenMP.cmake")
++if (USE_OPENMP)
++ include("cmake/OpenMP.cmake")
++endif()
+ include("cmake/TBB.cmake")
+ include("cmake/OpenCL.cmake")
+ include("cmake/platform.cmake")
+@@ -133,8 +135,12 @@ include(GNUInstallDirs)
+ include(CMakePackageConfigHelpers)
+
+ add_subdirectory(src)
+-add_subdirectory(examples)
+-add_subdirectory(tests)
++if(BUILD_EXAMPLES)
++ add_subdirectory(examples)
++endif()
++if(BUILD_TESTS)
++ add_subdirectory(tests)
++endif()
+
+ if(DNNL_INSTALL_MODE STREQUAL "BUNDLE")
+ install(FILES LICENSE DESTINATION ${CMAKE_INSTALL_PREFIX})