aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Graph/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/p5-Graph/Makefile')
-rw-r--r--math/p5-Graph/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/math/p5-Graph/Makefile b/math/p5-Graph/Makefile
new file mode 100644
index 000000000000..f1016df1c15d
--- /dev/null
+++ b/math/p5-Graph/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: math/p5-Graph
+# Date created: 09 October 2001
+# Whom: tobez
+#
+# $FreeBSD$
+#
+
+PORTNAME= Graph
+PORTVERSION= 0.201
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Graph
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Heap.pm:${PORTSDIR}/devel/p5-Heap
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Graph.3 \
+ Graph::BFS.3 \
+ Graph::Base.3 \
+ Graph::DFS.3 \
+ Graph::Directed.3 \
+ Graph::HeapElem.3 \
+ Graph::Traversal.3 \
+ Graph::Undirected.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>