aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-BigInt-GMP/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/p5-Math-BigInt-GMP/Makefile')
-rw-r--r--math/p5-Math-BigInt-GMP/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/math/p5-Math-BigInt-GMP/Makefile b/math/p5-Math-BigInt-GMP/Makefile
new file mode 100644
index 000000000000..82e6c60e7c76
--- /dev/null
+++ b/math/p5-Math-BigInt-GMP/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: math/p5-Math-BigInt-GMP
+# Date created: 7 February 2007
+# Whom: Maxime Henrion <mux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-BigInt-GMP
+PORTVERSION= 1.19
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Math::BigInt::GMP - Use the GMP library for Math::BigInt routines
+
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+BUILD_DEPENDS= p5-Math-BigInt>=1.78:${PORTSDIR}/math/p5-Math-BigInt
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS+= INC="-I${LOCALBASE}/include"
+
+MAN3= Math::BigInt::GMP.3
+
+.include <bsd.port.mk>