aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Currency/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/p5-Math-Currency/Makefile')
-rw-r--r--math/p5-Math-Currency/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/math/p5-Math-Currency/Makefile b/math/p5-Math-Currency/Makefile
index 2b07d48f1a93..fb5d6d144748 100644
--- a/math/p5-Math-Currency/Makefile
+++ b/math/p5-Math-Currency/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Math-Currency
-PORTVERSION= 0.39
+PORTVERSION= 0.40
CATEGORIES= math perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Math
@@ -16,11 +16,21 @@ MAINTAINER= mat@FreeBSD.org
COMMENT= Perl module for exact currency math with formatting and rounding
BUILD_DEPENDS= ${SITE_PERL}/Math/FixedPrecision.pm:${PORTSDIR}/math/p5-Math-FixedPrecision \
- ${SITE_PERL}/Math/BigFloat.pm:${PORTSDIR}/math/p5-Math-BigInt
+ ${SITE_PERL}/Math/BigFloat.pm:${PORTSDIR}/math/p5-Math-BigInt \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_MODBUILD= yes
MAN3= Math::Currency.3
+.if !defined(NOPORTDOCS)
+PORTDOCS= Changes
+
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
.include <bsd.port.mk>