aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Prime-Util/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/p5-Math-Prime-Util/Makefile')
-rw-r--r--math/p5-Math-Prime-Util/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/math/p5-Math-Prime-Util/Makefile b/math/p5-Math-Prime-Util/Makefile
new file mode 100644
index 000000000000..61a4563a32d4
--- /dev/null
+++ b/math/p5-Math-Prime-Util/Makefile
@@ -0,0 +1,27 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Math-Prime-Util
+PORTVERSION= 0.71
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Utilities related to prime numbers, including fast sieves and factoring
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+LIB_DEPENDS= libgmp.so:math/gmp
+RUN_DEPENDS= p5-Math-Prime-Util-GMP>=0.50:math/p5-Math-Prime-Util-GMP
+
+USES= perl5
+USE_PERL5= configure
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Math/Prime/Util/Util.so
+
+.include <bsd.port.mk>