aboutsummaryrefslogtreecommitdiff
path: root/math/pari/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/pari/Makefile')
-rw-r--r--math/pari/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/math/pari/Makefile b/math/pari/Makefile
index aa88b3543e2a..4864c6fd8d56 100644
--- a/math/pari/Makefile
+++ b/math/pari/Makefile
@@ -35,11 +35,17 @@ HAVE_EMACS!= which emacs || echo nope
PLIST= ${PKGDIR}/pkg-plist.emacs
.endif
-.if ${MACHINE_ARCH:L} == "amd64"
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
CFLAGS+= -fPIC
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not compile on sparc64"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-O3|"${CFLAGS}"|' ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>