aboutsummaryrefslogtreecommitdiff
path: root/math/pecl-big_int/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/pecl-big_int/Makefile')
-rw-r--r--math/pecl-big_int/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/math/pecl-big_int/Makefile b/math/pecl-big_int/Makefile
index 6398dcd0affc..02ada663f217 100644
--- a/math/pecl-big_int/Makefile
+++ b/math/pecl-big_int/Makefile
@@ -14,7 +14,6 @@ COMMENT= Functions for calculations with arbitrary length integers and bitsets
USE_PHP= yes
USE_PHPEXT= yes
-NO_STAGE= yes
DOCS= CREDITS INSTALL LICENSE README docs/index.html libbig_int/CREDITS \
libbig_int/LICENSE
@@ -22,16 +21,14 @@ EXAMPLES= bitset.php example.php rand.php RSA.php std_header.php
CONFIGURE_ARGS= --enable-big-int=shared
-.if !defined(NOPORTDOCS)
post-install:
- ${MKDIR} ${DOCSDIR}
- ${MKDIR} ${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
. for doc in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
. endfor
-. for test in ${EXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/tests/${test} ${EXAMPLESDIR}
+. for test in ${STAGEDIR}${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/tests/${test} ${STAGEDIR}${EXAMPLESDIR}
. endfor
-.endif
.include <bsd.port.mk>