aboutsummaryrefslogtreecommitdiff
path: root/math/plplot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/plplot/Makefile')
-rw-r--r--math/plplot/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index f19e0049f1d8..1a5f28b022e1 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -3,7 +3,7 @@
# Date created: 03 Oct 1997
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.3 1997/11/30 21:12:15 jseger Exp $
+# $Id: Makefile,v 1.4 1997/12/24 01:21:31 alex Exp $
#
DISTNAME= plplot4p99j
@@ -20,4 +20,11 @@ post-patch:
@perl -pi.bak -e "s|/usr/local/plplot/lib|${PREFIX}/lib/plplot|g;" \
${WRKSRC}/src/plctrl.c
+post-install:
+ if [ "${PORTOBJFORMAT}" = "elf" ]; then \
+ ${LN} -sf libplplotdX.so.4 ${PREFIX}/lib/libplplotdX.so; \
+ else \
+ ${LN} -sf libplplotdX.so.4.99 ${PREFIX}/lib/libplplotdX.so; \
+ fi
+
.include <bsd.port.mk>