aboutsummaryrefslogtreecommitdiff
path: root/math/py-numeric
diff options
context:
space:
mode:
Diffstat (limited to 'math/py-numeric')
-rw-r--r--math/py-numeric/Makefile47
-rw-r--r--math/py-numeric/distinfo1
-rw-r--r--math/py-numeric/pkg-comment1
-rw-r--r--math/py-numeric/pkg-descr20
-rw-r--r--math/py-numeric/pkg-plist49
5 files changed, 0 insertions, 118 deletions
diff --git a/math/py-numeric/Makefile b/math/py-numeric/Makefile
deleted file mode 100644
index 51524f96f432..000000000000
--- a/math/py-numeric/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-# New ports collection makefile for: numpy
-# Version required: 1.8
-# Date created: 20 April 1997
-# Whom: Thomas Gellekum <tg@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-DISTNAME= LLNLDistribution11
-PKGNAME= py-numeric-1.8
-CATEGORIES= math python
-MASTER_SITES= ftp://ftp-icf.llnl.gov/pub/python/
-EXTRACT_SUFX= .tgz
-
-MAINTAINER= tg@FreeBSD.org
-
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
-
-WRKSRC= ${WRKDIR}/${DISTNAME}/Numerical
-CONFIGURE_ENV= PREFIX=${PREFIX}
-ALL_TARGET= sharedmods
-MAKE_FLAGS+= 'OPT=${CFLAGS}'
-
-PYTHONSCRIPTDIR= ${PREFIX}/lib/python1.5
-NUMPYDIR= ${PYTHONSCRIPTDIR}/site-packages/numerical
-DOCDIR= ${PREFIX}/share/doc/py-numerical
-EXAMPLEDIR= ${PREFIX}/share/examples/py-numerical
-
-do-configure:
- @(cd ${WRKSRC} && ${CONFIGURE_ENV} python makethis.py)
-
-post-install:
- @${MKDIR} ${NUMPYDIR}
- ${INSTALL_DATA} ${WRKSRC}/Lib/* ${NUMPYDIR}
- @${PREFIX}/bin/python -O ${PYTHONSCRIPTDIR}/compileall.py ${NUMPYDIR}
- @${ECHO} "numerical" > ${NUMPYDIR}/../numerical.pth
- @${MKDIR} ${PREFIX}/include/python1.5/numerical
- ${INSTALL_DATA} ${WRKSRC}/Include/*object.h ${PREFIX}/include/python1.5/numerical
- @${MKDIR} ${EXAMPLEDIR}
- ${INSTALL_DATA} ${WRKSRC}/Demo/* ${EXAMPLEDIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/Doc/*.html ${DOCDIR}
-.endif
-
-.include <bsd.port.mk>
diff --git a/math/py-numeric/distinfo b/math/py-numeric/distinfo
deleted file mode 100644
index 8195abb118e7..000000000000
--- a/math/py-numeric/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (LLNLDistribution11.tgz) = 7ce5043ff3ec5d8202170c4d7892aa0e
diff --git a/math/py-numeric/pkg-comment b/math/py-numeric/pkg-comment
deleted file mode 100644
index 29f5536121ee..000000000000
--- a/math/py-numeric/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-The Numeric Extension to Python
diff --git a/math/py-numeric/pkg-descr b/math/py-numeric/pkg-descr
deleted file mode 100644
index 83bfbdb7b99d..000000000000
--- a/math/py-numeric/pkg-descr
+++ /dev/null
@@ -1,20 +0,0 @@
-The Numeric Extensions to Python (NumPy) give Python the number crunching
-power of numeric languages like Matlab and IDL while maintaining all of the
-advantages of the general-purpose programming language Python.
-
-These extensions add two new object types to Python, and then include a
-number of extensions that take advantage of these two new objects.
-
- * Multidimensional Array Objects
- + Efficient arrays of homogeneous machine types
- + Arbitrary number of dimensions
- + Sophisticated structural operations
- * Universal Function Objects
- + Supports mathematical functions on all python objects
- + Very efficient for Array Objects
- * Simple interfaces to existing numerical libraries:
- + Linear Algebra (LAPACK)
- + Fourier Transforms (FFTPACK)
- + Random Numbers (RANLIB)
-
-WWW: http://xfiles.llnl.gov/python.htm
diff --git a/math/py-numeric/pkg-plist b/math/py-numeric/pkg-plist
deleted file mode 100644
index e9df84da6b7a..000000000000
--- a/math/py-numeric/pkg-plist
+++ /dev/null
@@ -1,49 +0,0 @@
-include/python1.5/numerical/arrayobject.h
-include/python1.5/numerical/ufuncobject.h
-@dirrm include/python1.5/numerical
-lib/python1.5/site-packages/numerical/ArrayPrinter.py
-lib/python1.5/site-packages/numerical/ArrayPrinter.pyc
-lib/python1.5/site-packages/numerical/ArrayPrinter.pyo
-lib/python1.5/site-packages/numerical/FFT.py
-lib/python1.5/site-packages/numerical/FFT.pyc
-lib/python1.5/site-packages/numerical/FFT.pyo
-lib/python1.5/site-packages/numerical/LinearAlgebra.py
-lib/python1.5/site-packages/numerical/LinearAlgebra.pyc
-lib/python1.5/site-packages/numerical/LinearAlgebra.pyo
-lib/python1.5/site-packages/numerical/MLab.py
-lib/python1.5/site-packages/numerical/MLab.pyc
-lib/python1.5/site-packages/numerical/MLab.pyo
-lib/python1.5/site-packages/numerical/Matrix.py
-lib/python1.5/site-packages/numerical/Matrix.pyc
-lib/python1.5/site-packages/numerical/Matrix.pyo
-lib/python1.5/site-packages/numerical/Numeric.py
-lib/python1.5/site-packages/numerical/Numeric.pyc
-lib/python1.5/site-packages/numerical/Numeric.pyo
-lib/python1.5/site-packages/numerical/Precision.py
-lib/python1.5/site-packages/numerical/Precision.pyc
-lib/python1.5/site-packages/numerical/Precision.pyo
-lib/python1.5/site-packages/numerical/RandomArray.py
-lib/python1.5/site-packages/numerical/RandomArray.pyc
-lib/python1.5/site-packages/numerical/RandomArray.pyo
-lib/python1.5/site-packages/numerical/UserArray.py
-lib/python1.5/site-packages/numerical/UserArray.pyc
-lib/python1.5/site-packages/numerical/UserArray.pyo
-@dirrm lib/python1.5/site-packages/numerical
-lib/python1.5/site-packages/numerical.pth
-lib/python1.5/site-packages/_numpymodule.so
-lib/python1.5/site-packages/fftpack.so
-lib/python1.5/site-packages/lapack_lite.so
-lib/python1.5/site-packages/multiarraymodule.so
-lib/python1.5/site-packages/ranlib.so
-lib/python1.5/site-packages/umathmodule.so
-@unexec rmdir %B 2>/dev/null || true
-share/doc/py-numerical/doc.html
-share/doc/py-numerical/home.html
-@dirrm share/doc/py-numerical
-share/examples/py-numerical/life.py
-share/examples/py-numerical/life.pyc
-share/examples/py-numerical/mandelbrot.py
-share/examples/py-numerical/mandelbrot.pyc
-share/examples/py-numerical/sieve.py
-share/examples/py-numerical/sieve.pyc
-@dirrm share/examples/py-numerical