aboutsummaryrefslogtreecommitdiff
path: root/math/py-numpy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/py-numpy/Makefile')
-rw-r--r--math/py-numpy/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/math/py-numpy/Makefile b/math/py-numpy/Makefile
index c1dccd30e641..b67560a6c0a8 100644
--- a/math/py-numpy/Makefile
+++ b/math/py-numpy/Makefile
@@ -75,6 +75,8 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e "s+%%FC%%+${FC}+" ${WRKSRC}/numpy/distutils/fcompiler/gnu.py
@${CP} ${FILESDIR}/site.cfg ${WRKSRC}/site.cfg
+# ignore LDFLAGS from env, as it overrides internal flags (e.g. -shared) for some reason
+ @${REINPLACE_CMD} -e "s|'LDFLAGS'|None|" ${WRKSRC}/numpy/distutils/fcompiler/__init__.py
GCCLIBDIR_CMDS= ${FC} -print-file-name=libgfortran.so|${SED} -e s/libgfortran.so//
pre-configure: