aboutsummaryrefslogtreecommitdiff
path: root/math/py-pysparse/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/py-pysparse/Makefile')
-rw-r--r--math/py-pysparse/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/math/py-pysparse/Makefile b/math/py-pysparse/Makefile
index d756f98c2700..d8904ceae11d 100644
--- a/math/py-pysparse/Makefile
+++ b/math/py-pysparse/Makefile
@@ -13,8 +13,8 @@ COMMENT= Fast sparse matrix library for Python
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.2,1:math/py-numpy
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.2,1:math/py-numpy
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.2,1:math/py-numpy@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.2,1:math/py-numpy@${FLAVOR}
LIB_DEPENDS= liblapack.so:math/lapack \
libblas.so:math/blas \
libopenblas.so:math/openblas \
@@ -26,7 +26,7 @@ GH_TAGNAME= f8430bd
LDFLAGS+= -shared # Workaround for an obscure bug in py-numpy, see https://github.com/numpy/numpy/issues/7779
-USES= fortran python # fortran is needed for the correct build flags passed to py-numpy extension build process
+USES= fortran python:2.7 # fortran is needed for the correct build flags passed to py-numpy extension build process
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>