aboutsummaryrefslogtreecommitdiff
path: root/math/py-statsmodels/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/py-statsmodels/Makefile')
-rw-r--r--math/py-statsmodels/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/math/py-statsmodels/Makefile b/math/py-statsmodels/Makefile
index 18a8ee8bf7e4..9791ad05ad2a 100644
--- a/math/py-statsmodels/Makefile
+++ b/math/py-statsmodels/Makefile
@@ -3,8 +3,8 @@
PORTNAME= statsmodels
PORTVERSION= 0.6.1
+PORTREVISION= 1
CATEGORIES= math python
-MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= xmj@chaot.net
@@ -24,18 +24,12 @@ RUN_DEPENDS= ${PYNUMPY} \
OPTIONS_DEFINE= DOCS EXAMPLES
USES= python
-USE_PYTHON= py3kplist distutils concurrent
+USE_PYTHON= autoplist distutils concurrent
+USE_GITHUB= yes
+GH_TAGNAME= 8e812cd
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
-BUILD_DEPENDS+= sphinx-build:${PORTSDIR}/textproc/py-sphinx \
- ${PYTHON_PKGNAMEPREFIX}matplotlib>0:${PORTSDIR}/math/py-matplotlib \
- ipython:${PORTSDIR}/devel/ipython
-
-PYDISTUTILS_BUILD_TARGET+= build_sphinx
-.endif
-
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}/nonparametric/_smoothers_lowess.so
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}/nonparametric/linbin.so
@@ -43,7 +37,6 @@ post-install:
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.rst ${WRKSRC}/README_l1.txt ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/build/sphinx/html && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
.endif
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}