aboutsummaryrefslogtreecommitdiff
path: root/math/py-z3-solver/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/py-z3-solver/Makefile')
-rw-r--r--math/py-z3-solver/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/math/py-z3-solver/Makefile b/math/py-z3-solver/Makefile
index 38a4cac939c5..404779945f14 100644
--- a/math/py-z3-solver/Makefile
+++ b/math/py-z3-solver/Makefile
@@ -13,7 +13,9 @@ COMMENT= Python binding for Z3 Theorem Prover
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/../../../LICENSE.txt
-# CAVEAT: It should have LIB_DEPENDS=libz3.so:math/z3, but currently it rebuilds all code, see https://github.com/Z3Prover/z3/issues/1767
+BROKEN_i386= can't create dynamic relocation R_386_32 against symbol: .L.str in readonly segment; see https://github.com/Z3Prover/z3/issues/2442
+
+# CAVEAT: There should have LIB_DEPENDS=libz3.so:math/z3, but currently it rebuilds all code, see https://github.com/Z3Prover/z3/issues/1767
USES= compiler:c++11-lang python
USE_GITHUB= yes
@@ -23,8 +25,6 @@ USE_PYTHON= distutils autoplist
WRKSRC_SUBDIR= src/api/python
-CXXFLAGS+= -fPIC # failure message on 13-i386 suggested -fPIC, no other platforms experienced failures
-
post-patch: # https://github.com/Z3Prover/z3/issues/2131
@${REINPLACE_CMD} 's|…|...|' ${WRKSRC}/../../ast/recfun_decl_plugin.h