aboutsummaryrefslogtreecommitdiff
path: root/math/rascal/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/rascal/Makefile')
-rw-r--r--math/rascal/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/math/rascal/Makefile b/math/rascal/Makefile
index 2687c538ff0f..045f6877c959 100644
--- a/math/rascal/Makefile
+++ b/math/rascal/Makefile
@@ -26,6 +26,12 @@ ALL_TARGET= rascal grascal
MANCOMPRESSED= yes
MAN1= rascal.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+BROKEN= "Does not compile"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g ; \
s,g\+\+,${CXX},g ; \
@@ -33,4 +39,4 @@ post-patch:
s,gnome-config,${GNOME_CONFIG},g ; \
s,CC,CXX,g" ${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>