aboutsummaryrefslogtreecommitdiff
path: root/math/rpy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/rpy/Makefile')
-rw-r--r--math/rpy/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/math/rpy/Makefile b/math/rpy/Makefile
new file mode 100644
index 000000000000..269723e0d864
--- /dev/null
+++ b/math/rpy/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: rpy
+# Date created: Jan 14, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= rpy
+PORTVERSION= 0.3.1
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Python interface to the R Programming Language
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/Numeric.pth:${PORTSDIR}/math/py-numeric \
+ R:${PORTSDIR}/math/R-letter
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib/R/modules"
+
+.include <bsd.port.mk>