aboutsummaryrefslogtreecommitdiff
path: root/math/scilab/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/scilab/Makefile')
-rw-r--r--math/scilab/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index dbb6bb71e30c..7388afbc4cc4 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -115,6 +115,12 @@ TK_USE= XORG=x11
CONFIGURE_ARGS+= --without-openmp
.endif
+.include <bsd.port.pre.mk>
+
+.if ${JAVA_PORT_VERSION:M1.8.*}
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-Makefile.in
+.endif
+
post-patch:
@# Configure fixes
@${REINPLACE_CMD} -e 's|-ldl | |' ${WRKSRC}/configure
@@ -161,4 +167,4 @@ check test regression-test: build
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${_MAKE_JOBS} \
${MAKE_ARGS} check)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>