aboutsummaryrefslogtreecommitdiff
path: root/math/scilab
diff options
context:
space:
mode:
Diffstat (limited to 'math/scilab')
-rw-r--r--math/scilab/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index 97f990dd3b5f..7bdbbed14e31 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -110,8 +110,16 @@ TK_CONFIGURE_ON= --with-tk-library=${LOCALBASE}/lib \
TK_USES= tk
TK_USE= XORG=x11
+.if !exists(/usr/include/omp.h)
+CONFIGURE_ARGS+= --without-openmp
+.endif
+
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MOCAML} && empty(PORT_OPTIONS:MGUI)
+IGNORE= with OCAML option requies GUI. Please rerun 'make config' and select GUI
+.endif
+
.if ${PORT_OPTIONS:MGUI}
USE_JAVA= yes
# bsdjava (ie java/jdk16) doesn't have some "extra" classes that aren't in