aboutsummaryrefslogtreecommitdiff
path: root/math/sdpa/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/sdpa/files/Makefile')
-rw-r--r--math/sdpa/files/Makefile51
1 files changed, 0 insertions, 51 deletions
diff --git a/math/sdpa/files/Makefile b/math/sdpa/files/Makefile
deleted file mode 100644
index 3c311cff33ed..000000000000
--- a/math/sdpa/files/Makefile
+++ /dev/null
@@ -1,51 +0,0 @@
-#
-# Makefile for SDPA example(please use gmake)
-# Sample Makefile written by <maho@FreeBSD.org>
-#
-# $FreeBSD$
-
-PREFIX = %%PREFIX%%
-LOCALBASE = %%LOCALBASE%%
-LAPACK_LIB = %%LAPACK%% %%BLAS%%
-SDPA_LIB = -lsdpa
-SDPA_EXAMPLES = example1-1.exe example1-2.exe \
- example2-1.exe example2-2.exe \
- example3.exe example4.exe \
- example5.exe example6.exe
-
-SOURCES = example1-1.cpp example1-2.cpp \
- example2-1.cpp example2-2.cpp \
- example3.cpp example4.cpp \
- example5.cpp example6.cpp
-
-all: $(SDPA_EXAMPLES)
-
-clean:
- rm -f *.o *.exe
-
-example1-1.exe: example1-1.o
- $(CXX) $(CXXFLAGS) -o $@ example1-1.o -L$(PREFIX)/lib -L$(LOCALBASE)/lib $(LAPACK_LIB) $(SDPA_LIB) -lm
-
-example1-2.exe: example1-2.o
- $(CXX) $(CXXFLAGS) -o $@ example1-2.o -L$(PREFIX)/lib -L$(LOCALBASE)/lib $(LAPACK_LIB) $(SDPA_LIB) -lm
-
-example2-1.exe: example2-1.o
- $(CXX) $(CXXFLAGS) -o $@ example2-1.o -L$(PREFIX)/lib -L$(LOCALBASE)/lib $(LAPACK_LIB) $(SDPA_LIB) -lm
-
-example2-2.exe: example2-2.o
- $(CXX) $(CXXFLAGS) -o $@ example2-2.o -L$(PREFIX)/lib -L$(LOCALBASE)/lib $(LAPACK_LIB) $(SDPA_LIB) -lm
-
-example3.exe: example3.o
- $(CXX) $(CXXFLAGS) -o $@ example3.o -L$(PREFIX)/lib -L$(LOCALBASE)/lib $(LAPACK_LIB) $(SDPA_LIB) -lm
-
-example4.exe: example4.o
- $(CXX) $(CXXFLAGS) -o $@ example4.o -L$(PREFIX)/lib -L$(LOCALBASE)/lib $(LAPACK_LIB) $(SDPA_LIB) -lm
-
-example5.exe: example5.o
- $(CXX) $(CXXFLAGS) -o $@ example5.o -L$(PREFIX)/lib -L$(LOCALBASE)/lib $(LAPACK_LIB) $(SDPA_LIB) -lm
-
-example6.exe: example6.o
- $(CXX) $(CXXFLAGS) -o $@ example6.o -L$(PREFIX)/lib -L$(LOCALBASE)/lib $(LAPACK_LIB) $(SDPA_LIB) -lm
-
-.cpp.o:
- $(CXX) $(CXXFLAGS) -c -I$(PREFIX)/include -I$(LOCALBASE)/include -o $@ $< \ No newline at end of file