aboutsummaryrefslogtreecommitdiff
path: root/math/siag/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/siag/Makefile')
-rw-r--r--math/siag/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/math/siag/Makefile b/math/siag/Makefile
index 7483bb85c729..2ec79cc55c01 100644
--- a/math/siag/Makefile
+++ b/math/siag/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= siag
-PORTVERSION= 3.2.0
+PORTVERSION= 3.3.3
CATEGORIES= math
MASTER_SITES= ftp://ftp.edu.stockholm.se/pub/siag/ \
ftp://ftp.icm.edu.pl/site/siag/
@@ -14,27 +14,28 @@ MASTER_SITES= ftp://ftp.edu.stockholm.se/pub/siag/ \
MAINTAINER= mi@aldan.algebra.com
LIB_DEPENDS= Xaw3d.6:${PORTSDIR}/x11-toolkits/Xaw3d \
+ Magick:${PORTSDIR}/graphics/ImageMagick \
Xpm.4:${PORTSDIR}/graphics/xpm
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
mswordview:${PORTSDIR}/textproc/mswordview \
catdoc:${PORTSDIR}/textproc/catdoc
GNU_CONFIGURE= yes
-MAKEFLAGS= "-j 2"
+MAKE_ARGS= "-j 2"
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include -DX11BASE='\"${X11BASE}\"'
.if defined(GUILE)
LIB_DEPENDS+= guile.6:${PORTSDIR}/lang/guile
.endif
.if !defined(NOGDBM)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libgdbm.a:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
CPPFLAGS+= -DGDBM
.endif
.if !defined(NOT1)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libt1.a:${PORTSDIR}/devel/t1lib
+LIB_DEPENDS+= t1:${PORTSDIR}/devel/t1lib
.endif
.if !defined(NOTCL)
@@ -50,14 +51,15 @@ CONFIGURE_ENV+= LOCALBASE=${LOCALBASE} \
USE_X_PREFIX= yes
-MAN1= xedplus.1 xfiler.1 gvu.1 siod.1 siag.1 pw.1 egon.1 dummy_plugin.1
+MAN1= xedplus.1 xfiler.1 gvu.1 siod.1 siag.1 pw.1 egon.1 \
+ dummy_plugin.1 runcmd.1
post-install:
# Examples and documentation went into ${PREFIX}/share/doc
# Note, that the Siag's wordprocessor. the Pathetic Writer (or
# pw) is installed in ${PREFIX}/bin/pw. Depending on your
# users' PATH it may or may not interfere with simple
- # invocation of /usr/sbin/pw.
+ # invocation of pw(8) (which is in /usr/sbin).
@test -e ${PREFIX}/lib/X11/app-defaults/Siag && ${ECHO} \
"It seems, you have old app-defaults file(s) from Siag.\
Consider removing it(them) if new siag fails to come up" |\
@@ -70,5 +72,9 @@ post-patch:
${MV} $$m $$m.orig; \
${SED} s@doc/siag@share/doc/siag@ < $$m.orig > $$m; \
done
+ # Fixing configure to look for Xaw3d instead of XawM
+ ${MV} ${WRKSRC}/configure ${WRKSRC}/configure.XawM
+ ${SED} s/XawM/Xaw3d/g < ${WRKSRC}/configure.XawM > ${WRKSRC}/configure
+ ${CHMOD} +x ${WRKSRC}/configure
.include <bsd.port.mk>