aboutsummaryrefslogtreecommitdiff
path: root/math/snns/files
diff options
context:
space:
mode:
Diffstat (limited to 'math/snns/files')
-rw-r--r--math/snns/files/patch-ab20
-rw-r--r--math/snns/files/patch-ac15
-rw-r--r--math/snns/files/patch-ad11
-rw-r--r--math/snns/files/patch-ae11
-rw-r--r--math/snns/files/patch-af13
5 files changed, 70 insertions, 0 deletions
diff --git a/math/snns/files/patch-ab b/math/snns/files/patch-ab
new file mode 100644
index 000000000000..80342b770e1b
--- /dev/null
+++ b/math/snns/files/patch-ab
@@ -0,0 +1,20 @@
+--- kernel/sources/Makefile.orig Thu Sep 3 06:38:00 1998
++++ kernel/sources/Makefile Sat Dec 4 12:52:06 1999
+@@ -27,7 +27,7 @@
+ # Define final C-preprocessor options for the kernel
+ # Additional definitions like -I... and -D... go here
+ CPPFLAGS = -I../.. \
+- $(ENZOFLAGS)
++ $(ENZOFLAGS) -DHAVE_VALUES_H
+
+ # Here you may change the default C-compiler flags as set in
+ # ../../Makefile.def (not recommended)
+@@ -100,7 +100,7 @@
+ all: $(LIBKERNEL) $(LIBFUNCS)
+
+ $(KERNELBINDIR):
+- -mkdir $(KERNELBINDIR)
++ -mkdir -p $(KERNELBINDIR)
+
+ install: all $(KERNELBINDIR)
+ @echo "nothing to install"
diff --git a/math/snns/files/patch-ac b/math/snns/files/patch-ac
new file mode 100644
index 000000000000..9642768b93b8
--- /dev/null
+++ b/math/snns/files/patch-ac
@@ -0,0 +1,15 @@
+--- man/Makefile.orig Sat Dec 4 12:52:20 1999
++++ man/Makefile Sat Dec 4 12:52:35 1999
+@@ -45,10 +45,10 @@
+ @echo "nothing to make"
+
+ $(MANDIR):
+- -mkdir $(MANDIR)
++ -mkdir -p $(MANDIR)
+
+ $(MAN1DIR): $(MANDIR)
+- -mkdir $(MAN1DIR)
++ -mkdir -p $(MAN1DIR)
+
+ install-one: $(MAN1DIR)
+ for mantarget in $(MAN1FILES) ; do \
diff --git a/math/snns/files/patch-ad b/math/snns/files/patch-ad
new file mode 100644
index 000000000000..db89b0867794
--- /dev/null
+++ b/math/snns/files/patch-ad
@@ -0,0 +1,11 @@
+--- tools/sources/Makefile.orig Sat Dec 4 12:53:02 1999
++++ tools/sources/Makefile Sat Dec 4 12:53:17 1999
+@@ -110,7 +110,7 @@
+ tools: $(TOOLS_PRG) $(KRTOOLS_PRG) $(BATCH_PRG)
+
+ $(TOOLSBINDIR):
+- -mkdir $(TOOLSBINDIR)
++ -mkdir -p $(TOOLSBINDIR)
+
+ install: tools $(TOOLSBINDIR)
+ for tooltarget in $(TOOLS_PRG) $(KRTOOLS_PRG) $(BATCH_PRG) ; do \
diff --git a/math/snns/files/patch-ae b/math/snns/files/patch-ae
new file mode 100644
index 000000000000..544f0bbc9c1a
--- /dev/null
+++ b/math/snns/files/patch-ae
@@ -0,0 +1,11 @@
+--- xgui/sources/Makefile.orig Sat Dec 4 12:53:34 1999
++++ xgui/sources/Makefile Sat Dec 4 12:53:53 1999
+@@ -147,7 +147,7 @@
+ all: $(PROGRAM)
+
+ $(XGUIBINDIR):
+- -mkdir $(XGUIBINDIR)
++ -mkdir -p $(XGUIBINDIR)
+
+ install: all $(XGUIBINDIR)
+ $(INSTALL_PROGRAM) $(PROGRAM) $(XGUIBINDIR)
diff --git a/math/snns/files/patch-af b/math/snns/files/patch-af
new file mode 100644
index 000000000000..62bf3c29ae30
--- /dev/null
+++ b/math/snns/files/patch-af
@@ -0,0 +1,13 @@
+--- xgui/sources/ui_main.c.orig Sat Dec 4 13:08:46 1999
++++ xgui/sources/ui_main.c Sat Dec 4 13:08:04 1999
+@@ -329,8 +329,10 @@
+
+ UPDATE : 1.4.1990
+ ******************************************************************************/
++#include <floatingpoint.h>
+ void main (int argc, char **argv)
+ {
++ fpsetmask(0);
+ ui_toplevel = XtAppInitialize(&ui_appContext, "Popup", NULL, ZERO,
+ (int *) &argc, argv, fallback_resources,
+ NULL, ZERO);