aboutsummaryrefslogtreecommitdiff
path: root/math/superlu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/superlu/Makefile')
-rw-r--r--math/superlu/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/math/superlu/Makefile b/math/superlu/Makefile
index 545c4756bb94..145261c7e762 100644
--- a/math/superlu/Makefile
+++ b/math/superlu/Makefile
@@ -1,20 +1,19 @@
# New ports collection makefile for: SuperLU
-# Version required: 1.1
-# Date created: 31 Oct 97
-# Whom: Pedro Giffuni <giffunip@asme.org>
+# Version required: 2.0
+# Date created: 31 Oct 97
+# Whom: Pedro Giffuni <giffunip@asme.org>
#
# $FreeBSD$
#
-DISTNAME= superlu_1.1
-PKGNAME= superlu-1.1
+DISTNAME= superlu_2.0
+PKGNAME= superlu-2.0
CATEGORIES= math
-MASTER_SITES= ftp://ftp.cs.berkeley.edu/pub/lapack/SuperLU/ \
- ftp://ftp.u-aizu.ac.jp/pub/SciEng/numanal/cs.berkeley.edu/lapack/SuperLU/
+MASTER_SITES= http://www.nersc.gov/~xiaoye/SuperLU/
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${PREFIX}/lib/libblas.a:${PORTSDIR}/math/blas
+BUILD_DEPENDS= ${LOCALBASE}/lib/libblas.a:${PORTSDIR}/math/blas
WRKSRC= ${WRKDIR}/SuperLU
ALL_TARGET= superlulib
@@ -22,11 +21,12 @@ ALL_TARGET= superlulib
# NOTE: The Matlab interface was not built.
#
-post-install:
- $(INSTALL_DATA) ${WRKSRC}/libsuperlu.* ${PREFIX}/lib
- $(INSTALL_DATA) ${WRKSRC}/SRC/supermatrix.h ${PREFIX}/include
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libsuperlu.* ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/SRC/supermatrix.h ${PREFIX}/include
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/SuperLU
+ @${MKDIR} ${PREFIX}/share/doc/SuperLU
${INSTALL_DATA} ${WRKSRC}/INSTALL/*.ps ${PREFIX}/share/doc/SuperLU
.endif
+
.include <bsd.port.mk>