aboutsummaryrefslogtreecommitdiff
path: root/math/superlu_mt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/superlu_mt/Makefile')
-rw-r--r--math/superlu_mt/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/math/superlu_mt/Makefile b/math/superlu_mt/Makefile
index cf3afb7bd37b..80143825c86f 100644
--- a/math/superlu_mt/Makefile
+++ b/math/superlu_mt/Makefile
@@ -88,15 +88,15 @@ post-patch:
do-build:
cd ${WRKSRC} ; ${MAKE_CMD} LDFLAGS="${LDFLAGS}"
cd ${WRKSRC_SHARED} ; ${MAKE_CMD} LDFLAGS="${LDFLAGS}"
- ${RM} -rf ${WRKDIR}/tmp_static
+ ${RM} -r ${WRKDIR}/tmp_static
${MKDIR} ${WRKDIR}/tmp_static
cd ${WRKDIR}/tmp_static
${FIND} ${WRKSRC} -name "*\.a" -exec ${CP} {} ${WRKDIR}/tmp_static \;
- ${RM} -rf ${WRKDIR}/tmp_shared
+ ${RM} -r ${WRKDIR}/tmp_shared
${MKDIR} ${WRKDIR}/tmp_shared
${FIND} ${WRKSRC_SHARED} -name "*\.a" -exec ${CP} {} ${WRKDIR}/tmp_shared \;
@cd ${WRKDIR}/tmp_shared ; for i in `ls *.a | ${SED} 's/\.a//' `; do \
- ${RM} -f $${i}.so.* $${i}.so ; \
+ ${RM} $${i}.so.* $${i}.so ; \
${FC} ${CFLAGS} ${FPIC} ${LDFLAGS} -shared -o $${i}.so.${SVERSION} \
-Wl,-soname,$${i}.so.${SVERSION} -Wl,--allow-multiple-definition \
-Wl,--whole-archive $${i}.a -Wl,--no-whole-archive -Wl,--as-needed; \