aboutsummaryrefslogtreecommitdiff
path: root/math/tblis/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/tblis/Makefile')
-rw-r--r--math/tblis/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/math/tblis/Makefile b/math/tblis/Makefile
index 322042dff34a..d0d8c6debd18 100644
--- a/math/tblis/Makefile
+++ b/math/tblis/Makefile
@@ -12,6 +12,8 @@ COMMENT= Framework for performing tensor operations
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_aarch64= fails to compile: include_configs.hpp:2:10: fatal error: 'configs/armv7a/config.hpp' file not found
+BROKEN_armv6= fails to compile: include_configs.hpp:2:10: fatal error: 'configs/armv7a/config.hpp' file not found
NOT_FOR_ARCHS= i386
NOT_FOR_ARCHS_REASON= i386 requires SSE
@@ -19,12 +21,12 @@ OPTIONS_DEFINE= PARA
PARA_DESC= use pthread parallelization
OPTIONS_DEFAULT= PARA
-USE_GITHUB= yes
-GH_ACCOUNT= devinamatthews
-
USES= gmake libtool
USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= devinamatthews
+
HAS_CONFIGURE= yes
PARA_CONFIGURE_ON= --enable-thread-model=pthreads