aboutsummaryrefslogtreecommitdiff
path: root/math/xgfe/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/xgfe/Makefile')
-rw-r--r--math/xgfe/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/math/xgfe/Makefile b/math/xgfe/Makefile
new file mode 100644
index 000000000000..7ce80a21b125
--- /dev/null
+++ b/math/xgfe/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: xgfe
+# Date created: 24 March 1998
+# Whom: Matthew Hunt <mph@pobox.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xgfe
+PORTVERSION= 2.0
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= mph
+
+MAINTAINER= mph@freebsd.org
+
+RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
+
+USE_QT_VER= 1
+USE_X_PREFIX= yes
+
+MAKE_ENV= X11BASE=$(X11BASE) PREFIX=$(PREFIX)
+.if defined(NOPORTDOCS)
+MAKE_ENV+= NOPORTDOCS=$(NOPORTDOCS)
+.endif
+
+WRKSRC= $(WRKDIR)/$(DISTNAME)/source
+
+post-extract:
+ cd $(WRKSRC) && ${RM} Makefile && ${LN} -s Makefile.freebsd-gcc Makefile
+
+.include <bsd.port.mk>