aboutsummaryrefslogtreecommitdiff
path: root/math/xspread/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/xspread/Makefile')
-rw-r--r--math/xspread/Makefile47
1 files changed, 38 insertions, 9 deletions
diff --git a/math/xspread/Makefile b/math/xspread/Makefile
index b36929c5de02..25d5748e4409 100644
--- a/math/xspread/Makefile
+++ b/math/xspread/Makefile
@@ -1,18 +1,47 @@
# New ports collection makefile for: xspread
-# Version required: 2.1
+# Version required: 3.1.1c
# Date created: 28 June 1995
# Whom: janek@gaja.ipan.lublin.pl
#
+# $FreeBSD$
+#
-DISTNAME= xspread2.1
-PKGNAME= xspread-2.1
+DISTNAME= xspread3.1.1c
+PKGNAME= xspread-3.1.1c
CATEGORIES= math
-MASTER_SITES= ftp://sunsite.unc.edu/pub/Linux/distributions/slackware/source/xap/xspread/
-# ${MASTER_SITE_SUNSITE} isn't appropriate because distributions/ isn't
-# mirrored.
+MASTER_SITES= http://www.linuxberg.com/files/x11/office/
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_XLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LIBS="-L${X11BASE}/lib"
+
+INSTALL_TARGET= install install.man
+MAN1= xspread.1 pxspread.1
+
+XS_DIR= ${PREFIX}/share/xspread
+
+post-extract:
+.for file in config.cache config.h config.log config.status
+ @${RM} ${WRKSRC}/${file} || ${TRUE}
+.endfor
-USE_IMAKE= yes
-USE_GMAKE= yes
-MAN1= xspread.1
+post-install:
+.if !defined(NOPORTDOCS)
+ @find ${WRKSRC} -name "*.tmp" -delete || ${TRUE}
+ @${MKDIR} ${XS_DIR}
+ @${MKDIR} ${XS_DIR}/doc
+ @${MKDIR} ${XS_DIR}/documents
+ @${MKDIR} ${XS_DIR}/sample_files
+ @${MKDIR} ${XS_DIR}/tests
+ ${INSTALL_DATA} ${WRKSRC}/README ${XS_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/x/notes ${XS_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${XS_DIR}/doc
+ ${INSTALL_DATA} ${WRKSRC}/documents/* ${XS_DIR}/documents
+ ${INSTALL_DATA} ${WRKSRC}/sample_files/* ${XS_DIR}/sample_files
+ ${INSTALL_DATA} ${WRKSRC}/tests/* ${XS_DIR}/tests
+.endif
.include <bsd.port.mk>