aboutsummaryrefslogtreecommitdiff
path: root/math/yacas/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/yacas/Makefile')
-rw-r--r--math/yacas/Makefile47
1 files changed, 24 insertions, 23 deletions
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 4866286735d1..c06b1fc06feb 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -13,39 +13,40 @@ COMMENT= Yet Another Computer Algebra System
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-OPTIONS_DEFINE= DOCS
-
+USES= compiler:c++11-lib libtool
GNU_CONFIGURE= yes
-USES= libtool
+CONFIGURE_ARGS= --with-html-dir=${DOCSDIR}
INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
-.include <bsd.port.options.mk>
+PORTDOCS= *
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile with GCC 4.2
-.endif
+OPTIONS_DEFINE= DOCS
-.if ${PORT_OPTIONS:MDOCS}
-CONFIGURE_ARGS+=--enable-html-doc --with-html-dir=${DOCSDIR}
-PORTDOCS= *
-USES+= perl5
-USE_PERL5= build
-.else
-CONFIGURE_ARGS+=--disable-html-doc
+DOCS_USES= perl5
+DOCS_USE= perl5=build
+DOCS_CONFIGURE_ENABLE= html-doc
+
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == "gcc"
+CPPFLAGS+= -D_GLIBCXX_USE_C99
.endif
post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|"GNU strip"|"strip"|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/src/yacasmain.cpp
# Can't use USES=shebangfix here, cause the path appears several
# times in the file.
- @${REINPLACE_CMD} -e 's| /bin/bash| ${LOCALBASE}/bin/bash|g' \
- ${WRKSRC}/tests/test-yacas
- @${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' \
- ${WRKSRC}/src/yacasmain.cpp
+ @${REINPLACE_CMD} -e \
+ 's| /bin/bash| ${LOCALBASE}/bin/bash|g' \
+ ${WRKSRC}/tests/test-yacas
regression-test: build
-# This requires bash. I don't add it as a dependency to the port, as it's
-# not needed for the general use.
- @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} \
- ${MAKEFILE} check ${MAKE_ARGS})
+# This requires bash. I don't add it as a dependency to the port, as
+# it's not needed for the general use.
+ @(cd ${WRKSRC} && ${DO_MAKE_BUILD} check)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>