aboutsummaryrefslogtreecommitdiff
path: root/math/yacas/files
diff options
context:
space:
mode:
Diffstat (limited to 'math/yacas/files')
-rw-r--r--math/yacas/files/patch-CMakeLists-docs.txt18
-rw-r--r--math/yacas/files/patch-src_mathcommands.cpp2
-rw-r--r--math/yacas/files/patch-src_yacasmain.cpp2
3 files changed, 20 insertions, 2 deletions
diff --git a/math/yacas/files/patch-CMakeLists-docs.txt b/math/yacas/files/patch-CMakeLists-docs.txt
new file mode 100644
index 000000000000..90ca38b8fb26
--- /dev/null
+++ b/math/yacas/files/patch-CMakeLists-docs.txt
@@ -0,0 +1,18 @@
+--- CMakeLists-docs.txt.orig 2016-04-08 09:58:59 UTC
++++ CMakeLists-docs.txt
+@@ -39,7 +39,7 @@ add_custom_target(yacas_docs ALL
+ "${SPHINX_SINGLEHTML_DIR}"
+ COMMENT "Building HTML documentation with Sphinx")
+
+-install (DIRECTORY "${SPHINX_SINGLEHTML_DIR}" DESTINATION share/yacas/documentation COMPONENT doc)
++install (DIRECTORY "${SPHINX_SINGLEHTML_DIR}" DESTINATION ${DOCSDIR} COMPONENT doc)
+
+ if (ENABLE_OLD_DOCS)
+
+@@ -161,4 +161,4 @@ if (ENABLE_OLD_DOCS)
+
+ install (FILES ${HTML_BOOKS} ${HTML_CHAPTERS} DESTINATION share/yacas/documentation COMPONENT doc)
+
+-endif ()
+\ No newline at end of file
++endif ()
diff --git a/math/yacas/files/patch-src_mathcommands.cpp b/math/yacas/files/patch-src_mathcommands.cpp
index caf0c481bc4d..9abc90cca6d4 100644
--- a/math/yacas/files/patch-src_mathcommands.cpp
+++ b/math/yacas/files/patch-src_mathcommands.cpp
@@ -1,4 +1,4 @@
---- src/mathcommands.cpp.orig 2016-02-04 14:54:05 UTC
+--- src/mathcommands.cpp.orig 2016-03-11 09:22:12 UTC
+++ src/mathcommands.cpp
@@ -23,6 +23,7 @@
#include "yacas/arggetter.h"
diff --git a/math/yacas/files/patch-src_yacasmain.cpp b/math/yacas/files/patch-src_yacasmain.cpp
index 6cf8bbea68f8..463ab465f772 100644
--- a/math/yacas/files/patch-src_yacasmain.cpp
+++ b/math/yacas/files/patch-src_yacasmain.cpp
@@ -1,4 +1,4 @@
---- src/yacasmain.cpp.orig 2016-03-04 15:08:05 UTC
+--- src/yacasmain.cpp.orig 2016-03-11 09:22:12 UTC
+++ src/yacasmain.cpp
@@ -72,6 +72,7 @@
#if defined (__FreeBSD__) || defined (__DragonFly__)