aboutsummaryrefslogtreecommitdiff
path: root/math/z3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/z3/Makefile')
-rw-r--r--math/z3/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/math/z3/Makefile b/math/z3/Makefile
index a399576f3c84..2a49d247d011 100644
--- a/math/z3/Makefile
+++ b/math/z3/Makefile
@@ -2,8 +2,7 @@
PORTNAME= z3
DISTVERSIONPREFIX= ${PORTNAME}-
-DISTVERSION= 4.7.1
-PORTREVISION= 1
+DISTVERSION= 4.8.3
CATEGORIES= math
MAINTAINER= arrowd@FreeBSD.org
@@ -16,6 +15,10 @@ USES= compiler:c++11-lang python:2.7,build
USE_GITHUB= yes
GH_ACCOUNT= Z3Prover
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+USE_LDCONFIG= yes
+
OPTIONS_DEFINE= DEBUG STATIC GMP
OPTIONS_DEFAULT= STATIC
@@ -28,13 +31,9 @@ STATIC_CONFIGURE_ON= --staticlib
GMP_DESC= Use GMP library for AP arithmetic
GMP_CONFIGURE_ON= --gmp
-GMP_CXXFLAGS= -I${LOCALBASE}/include
-GMP_LDFLAGS= -L${LOCALBASE}/lib
+GMP_USES= localbase:ldflags
GMP_LIB_DEPENDS= libgmp.so:math/gmp
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX}
-USE_LDCONFIG= yes
LDFLAGS_i386= -Wl,-znotext
BUILD_WRKSRC= ${WRKSRC}/build
INSTALL_WRKSRC= ${WRKSRC}/build