aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/hs-Agda-executable/Makefile21
-rw-r--r--math/hs-Agda-executable/distinfo2
-rw-r--r--math/hs-Agda-executable/pkg-descr5
-rw-r--r--math/hs-Agda/Makefile23
-rw-r--r--math/hs-Agda/distinfo4
-rw-r--r--math/hs-Agda/files/patch-Agda.cabal47
-rw-r--r--math/hs-Agda/files/patch-src__full__Agda__Compiler__MAlonzo__Compiler.hs11
-rw-r--r--math/hs-Agda/files/patch-src__full__Agda__Syntax__Abstract__Name.hs24
-rw-r--r--math/hs-Agda/files/patch-src__full__Agda__Syntax__Common.hs13
-rw-r--r--math/hs-Agda/files/patch-src__full__Agda__Termination__Lexicographic.hs11
-rw-r--r--math/hs-Agda/files/patch-src__full__Agda__TypeChecking__Serialise.hs11
-rw-r--r--math/hs-Agda/files/patch-src__full__Agda__Utils__Pointer.hs11
-rw-r--r--math/hs-Agda/pkg-message9
-rw-r--r--math/hs-NumInstances/Makefile3
-rw-r--r--math/hs-NumInstances/distinfo4
-rw-r--r--math/hs-comonad-transformers/Makefile1
-rw-r--r--math/hs-comonad/Makefile2
-rw-r--r--math/hs-comonad/distinfo4
-rw-r--r--math/hs-comonads-fd/Makefile1
-rw-r--r--math/hs-contravariant/Makefile5
-rw-r--r--math/hs-contravariant/distinfo4
-rw-r--r--math/hs-contravariant/files/patch-contravariant.cabal12
-rw-r--r--math/hs-data-lens-template/Makefile2
-rw-r--r--math/hs-data-lens/Makefile2
-rw-r--r--math/hs-distributive/Makefile2
-rw-r--r--math/hs-distributive/distinfo4
-rw-r--r--math/hs-groupoids/Makefile1
-rw-r--r--math/hs-math-functions/Makefile3
-rw-r--r--math/hs-math-functions/distinfo4
-rw-r--r--math/hs-pointed/Makefile1
-rw-r--r--math/hs-semigroupoid-extras/Makefile1
-rw-r--r--math/hs-semigroupoids/Makefile1
-rw-r--r--math/hs-statistics/Makefile2
-rw-r--r--math/hs-vector-space/Makefile2
35 files changed, 106 insertions, 148 deletions
diff --git a/math/Makefile b/math/Makefile
index 7ad6fe32ac5c..c855f02a45cd 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -155,7 +155,6 @@
SUBDIR += grpn
SUBDIR += gsl
SUBDIR += hs-Agda
- SUBDIR += hs-Agda-executable
SUBDIR += hs-NumInstances
SUBDIR += hs-categories
SUBDIR += hs-comonad
diff --git a/math/hs-Agda-executable/Makefile b/math/hs-Agda-executable/Makefile
deleted file mode 100644
index 44e6d041df17..000000000000
--- a/math/hs-Agda-executable/Makefile
+++ /dev/null
@@ -1,21 +0,0 @@
-# Created by: Giuseppe Pilichi aka Jacula Modyun <jacula@gmail.com>
-# $FreeBSD$
-
-PORTNAME= Agda-executable
-PORTVERSION= 2.3.0.1
-PORTREVISION= 3
-CATEGORIES= math haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= Command-line program for type-checking and compiling Agda programs
-
-CABAL_SETUP= Setup.hs
-USE_CABAL= Agda>=2.3.0 Agda<2.3.1
-
-USE_ICONV= yes
-
-EXECUTABLE= agda
-STANDALONE= yes
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/math/hs-Agda-executable/distinfo b/math/hs-Agda-executable/distinfo
deleted file mode 100644
index 6adb590872cb..000000000000
--- a/math/hs-Agda-executable/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (cabal/Agda-executable-2.3.0.1.tar.gz) = 614594c414c828c87abb1913741db66447c09617d57b92e58ffe445ceffed694
-SIZE (cabal/Agda-executable-2.3.0.1.tar.gz) = 1765
diff --git a/math/hs-Agda-executable/pkg-descr b/math/hs-Agda-executable/pkg-descr
deleted file mode 100644
index e6525337a1d7..000000000000
--- a/math/hs-Agda-executable/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-This package provides a command-line program for type-checking and compiling
-Agda programs. The program can also generate hyperlinked, highlighted HTML
-files from Agda sources.
-
-WWW: http://wiki.portal.chalmers.se/agda/
diff --git a/math/hs-Agda/Makefile b/math/hs-Agda/Makefile
index a323aeef942a..d86e179601d9 100644
--- a/math/hs-Agda/Makefile
+++ b/math/hs-Agda/Makefile
@@ -2,42 +2,33 @@
# $FreeBSD$
PORTNAME= Agda
-PORTVERSION= 2.3.0.1
-PORTREVISION= 3
+PORTVERSION= 2.3.2
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
-COMMENT= A dependently typed functional programming language and proof assistant
+COMMENT= Dependently typed functional programming language and proof assistant
CABAL_SETUP= Setup.hs
-USE_CABAL= hashable>=1.2 hashtables haskeline>=0.6.3.2 \
- haskell-src-exts>=1.9.6 mtl QuickCheck>=2.3 syb>=0.1 \
+USE_CABAL= geniplate>=0.6.0.3 hashable>=1.2 hashtables \
+ haskeline>=0.6.3.2 haskell-src-exts>=1.9.6 mtl \
+ QuickCheck>=2.3 parallel syb>=0.1 unordered-containers>=0.2 \
xhtml zlib>=0.4.0.1
USE_ALEX= yes
USE_HAPPY= yes
USE_ICONV= yes
-EXECUTABLE= agda-mode
+EXECUTABLE= agda-mode agda
INSTALL_PORTDATA= (cd ${WRKSRC} && ${INSTALL_DATA} README ${DATADIR}; \
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DATADIR})
-SHOW_PKGMSG= yes
+OPTIONS_DEFINE= EPIC
-OPTIONS_DEFINE= USE_LOCALE EPIC
-
-USE_LOCALE_DESC= Use encoding specified by the locale
EPIC_DESC= Install the Epic compiler
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
-.if ${PORT_OPTIONS:MUSE_LOCALE}
-CONFIGURE_ARGS+= --flags="use-locale"
-.else
-CONFIGURE_ARGS+= --flags="-use-locale"
-.endif
-
.if ${PORT_OPTIONS:MEPIC}
CONFIGURE_ARGS+= --flags="epic"
USE_CABAL+= epic>=0.1.13
diff --git a/math/hs-Agda/distinfo b/math/hs-Agda/distinfo
index 5ed05c7e5708..485c853062a9 100644
--- a/math/hs-Agda/distinfo
+++ b/math/hs-Agda/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/Agda-2.3.0.1.tar.gz) = 5cc016a6cf113979d92af05c10b1e92dead4bf87861086177a017ce1d7605338
-SIZE (cabal/Agda-2.3.0.1.tar.gz) = 612342
+SHA256 (cabal/Agda-2.3.2.tar.gz) = d47a0b2a0806ea5c109b59280211a47b980b47a8f6ac0ab9fca673f3d4c6e0f6
+SIZE (cabal/Agda-2.3.2.tar.gz) = 726462
diff --git a/math/hs-Agda/files/patch-Agda.cabal b/math/hs-Agda/files/patch-Agda.cabal
index ad9b3b70f9a2..208d469dd4d5 100644
--- a/math/hs-Agda/files/patch-Agda.cabal
+++ b/math/hs-Agda/files/patch-Agda.cabal
@@ -1,38 +1,13 @@
---- ./Agda.cabal.orig 2012-03-12 11:09:34.000000000 +0100
-+++ ./Agda.cabal 2013-02-05 04:15:30.000000000 +0100
-@@ -71,13 +71,13 @@
- if flag(use-locale)
- build-depends: base >= 4.2 && < 4.6
- else
-- build-depends: base == 4.1.*,
-+ build-depends: base >= 4.1,
- utf8-string == 0.3.*
- if flag(epic)
- build-depends: epic >= 0.1.13 && < 0.10
-- build-depends: mtl == 2.0.*,
-- QuickCheck >= 2.3 && < 2.5,
-- haskell-src-exts >= 1.9.6 && < 1.12,
-+ build-depends: mtl >= 2.0,
-+ QuickCheck >= 2.3 && < 2.6,
-+ haskell-src-exts >= 1.9.6,
- containers >= 0.1 && < 0.5,
- pretty >= 1.0 && < 1.2,
- directory >= 1.0 && < 1.2,
-@@ -90,7 +90,7 @@
+--- ./Agda.cabal.orig 2012-11-12 01:25:25.000000000 +0100
++++ ./Agda.cabal 2013-03-09 17:44:08.000000000 +0100
+@@ -82,8 +82,8 @@
process >= 1.0.1.0 && < 1.2,
- haskeline >= 0.6.3.2 && < 0.7,
+ haskeline >= 0.6.3.2 && < 0.8,
xhtml == 3000.2.*,
-- hashable == 1.1.*,
-+ hashable == 1.2.*,
- hashtables == 1.0.*,
- syb >= 0.1 && < 0.4
- build-tools: happy >= 1.15 && < 2,
-@@ -334,7 +334,7 @@
- if flag(use-locale)
- build-depends: base >= 4.2 && < 4.6
- else
-- build-depends: base == 4.1.*,
-+ build-depends: base >= 4.1,
- utf8-string == 0.3.*
- build-depends: filepath >= 1.1 && < 1.4,
- process >= 1.0.1.0 && < 1.2,
+- hashable >= 1.1.2.3 && < 1.2,
+- hashtables == 1.0.*,
++ hashable >= 1.1.2.3 && < 1.3,
++ hashtables == 1.1.*,
+ geniplate >= 0.6.0.3 && < 0.7,
+ parallel < 3.3,
+ deepseq == 1.3.*,
diff --git a/math/hs-Agda/files/patch-src__full__Agda__Compiler__MAlonzo__Compiler.hs b/math/hs-Agda/files/patch-src__full__Agda__Compiler__MAlonzo__Compiler.hs
deleted file mode 100644
index bae4ce30dd13..000000000000
--- a/math/hs-Agda/files/patch-src__full__Agda__Compiler__MAlonzo__Compiler.hs
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/full/Agda/Compiler/MAlonzo/Compiler.hs.orig 2012-03-12 11:09:33.000000000 +0100
-+++ ./src/full/Agda/Compiler/MAlonzo/Compiler.hs 2012-04-08 22:51:55.000000000 +0200
-@@ -466,7 +466,7 @@
- ]
- where
- parse = HS.parseWithMode
-- HS.defaultParseMode{HS.extensions = [HS.ExplicitForall]}
-+ HS.defaultParseMode{HS.extensions = [HS.ExplicitForAll]}
-
- ok (HS.ParseOk d) = d
- ok HS.ParseFailed{} = __IMPOSSIBLE__
diff --git a/math/hs-Agda/files/patch-src__full__Agda__Syntax__Abstract__Name.hs b/math/hs-Agda/files/patch-src__full__Agda__Syntax__Abstract__Name.hs
new file mode 100644
index 000000000000..5108666a5839
--- /dev/null
+++ b/math/hs-Agda/files/patch-src__full__Agda__Syntax__Abstract__Name.hs
@@ -0,0 +1,24 @@
+--- ./src/full/Agda/Syntax/Abstract/Name.hs.orig 2012-11-12 01:25:21.000000000 +0100
++++ ./src/full/Agda/Syntax/Abstract/Name.hs 2013-02-10 15:14:44.000000000 +0100
+@@ -239,8 +239,8 @@
+ show x = show (nameConcrete x) -- ++ "|" ++ show (nameId x)
+
+ instance Hashable Name where
+- {-# INLINE hash #-}
+- hash = hash . nameId
++ {-# INLINE hashWithSalt #-}
++ hashWithSalt salt = hashWithSalt salt . nameId
+
+ instance Show QName where
+ show q = concat $ intersperse "." $ map show $ qnameToList q
+@@ -255,8 +255,8 @@
+ compare = compare `on` qnameName
+
+ instance Hashable QName where
+- {-# INLINE hash #-}
+- hash = hash . qnameName
++ {-# INLINE hashWithSalt #-}
++ hashWithSalt salt = hashWithSalt salt . qnameName
+
+ instance HasRange Name where
+ getRange = getRange . nameConcrete
diff --git a/math/hs-Agda/files/patch-src__full__Agda__Syntax__Common.hs b/math/hs-Agda/files/patch-src__full__Agda__Syntax__Common.hs
new file mode 100644
index 000000000000..b071c8448e13
--- /dev/null
+++ b/math/hs-Agda/files/patch-src__full__Agda__Syntax__Common.hs
@@ -0,0 +1,13 @@
+--- ./src/full/Agda/Syntax/Common.hs.orig 2012-11-12 01:25:21.000000000 +0100
++++ ./src/full/Agda/Syntax/Common.hs 2013-02-10 15:12:42.000000000 +0100
+@@ -272,8 +272,8 @@
+ fromEnum (NameId n _) = fromIntegral n
+
+ instance Hashable NameId where
+- {-# INLINE hash #-}
+- hash (NameId n m) = hash (n, m)
++ {-# INLINE hashWithSalt #-}
++ hashWithSalt salt (NameId n m) = hashWithSalt salt (n, m)
+
+ newtype Constr a = Constr a
+
diff --git a/math/hs-Agda/files/patch-src__full__Agda__Termination__Lexicographic.hs b/math/hs-Agda/files/patch-src__full__Agda__Termination__Lexicographic.hs
deleted file mode 100644
index 907f0bed5274..000000000000
--- a/math/hs-Agda/files/patch-src__full__Agda__Termination__Lexicographic.hs
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/full/Agda/Termination/Lexicographic.hs.orig 2012-03-12 11:09:33.000000000 +0100
-+++ ./src/full/Agda/Termination/Lexicographic.hs 2012-10-03 23:48:30.000000000 +0200
-@@ -230,7 +230,7 @@
- , quickCheck' prop_fromDiagonals
- , quickCheck' prop_newBehaviour
- , quickCheckWith' stdArgs{ maxSuccess = 50
-- , maxDiscard = 200
-+ , maxDiscardRatio = 200
- , maxSize = 20
- }
- prop_lexOrder
diff --git a/math/hs-Agda/files/patch-src__full__Agda__TypeChecking__Serialise.hs b/math/hs-Agda/files/patch-src__full__Agda__TypeChecking__Serialise.hs
deleted file mode 100644
index ef6fa31298eb..000000000000
--- a/math/hs-Agda/files/patch-src__full__Agda__TypeChecking__Serialise.hs
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/full/Agda/TypeChecking/Serialise.hs.orig 2012-03-12 11:09:33.000000000 +0100
-+++ ./src/full/Agda/TypeChecking/Serialise.hs 2013-02-05 04:30:03.000000000 +0100
-@@ -119,7 +119,7 @@
- -- | With direct access to the internals of 'TypeRep' this instance
- -- could presumably be improved.
- instance Hashable TypeRep' where
-- hash = hash . show . unTypeRep'
-+ hashWithSalt n = hashWithSalt n . show . unTypeRep'
-
- data St = St
- { nodeE :: !(Array Int32 Node)
diff --git a/math/hs-Agda/files/patch-src__full__Agda__Utils__Pointer.hs b/math/hs-Agda/files/patch-src__full__Agda__Utils__Pointer.hs
new file mode 100644
index 000000000000..1d480e01d10b
--- /dev/null
+++ b/math/hs-Agda/files/patch-src__full__Agda__Utils__Pointer.hs
@@ -0,0 +1,11 @@
+--- ./src/full/Agda/Utils/Pointer.hs.orig 2012-11-12 01:25:22.000000000 +0100
++++ ./src/full/Agda/Utils/Pointer.hs 2013-02-10 15:11:53.000000000 +0100
+@@ -71,7 +71,7 @@
+ compare = compare `on` ptrTag
+
+ instance Hashable (Ptr a) where
+- hash = hash . ptrTag
++ hashWithSalt salt = hashWithSalt salt . ptrTag
+
+ instance NFData (Ptr a) where
+
diff --git a/math/hs-Agda/pkg-message b/math/hs-Agda/pkg-message
deleted file mode 100644
index 10d2fc595c34..000000000000
--- a/math/hs-Agda/pkg-message
+++ /dev/null
@@ -1,9 +0,0 @@
-Note that if you want to use the command-line program (agda), then
-you should also install the Agda-executable package. The Agda
-package includes an Emacs mode for Agda, but you need to set up the
-Emacs mode yourself (for instance by running agda-mode setup; see
-the README).
-
-Note also that this library does not follow the package versioning
-policy, because the library is only intended to be used by the Emacs
-mode and the Agda-executable package.
diff --git a/math/hs-NumInstances/Makefile b/math/hs-NumInstances/Makefile
index d1e974d076eb..6ab70bcd169f 100644
--- a/math/hs-NumInstances/Makefile
+++ b/math/hs-NumInstances/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= NumInstances
-PORTVERSION= 1.0
-PORTREVISION= 4
+PORTVERSION= 1.2
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-NumInstances/distinfo b/math/hs-NumInstances/distinfo
index eeddcb7b2867..769849faf738 100644
--- a/math/hs-NumInstances/distinfo
+++ b/math/hs-NumInstances/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/NumInstances-1.0.tar.gz) = dea19248d921dcb90c28d0ebeddbc2c76840bc2545762c1442aea8caa91eafba
-SIZE (cabal/NumInstances-1.0.tar.gz) = 2695
+SHA256 (cabal/NumInstances-1.2.tar.gz) = a95c45280f794ef54ac1968a2938c2a87feb7c0c42e3923ea326bc0ee0904668
+SIZE (cabal/NumInstances-1.2.tar.gz) = 3701
diff --git a/math/hs-comonad-transformers/Makefile b/math/hs-comonad-transformers/Makefile
index 753c865fb419..f63e2d261804 100644
--- a/math/hs-comonad-transformers/Makefile
+++ b/math/hs-comonad-transformers/Makefile
@@ -2,6 +2,7 @@
PORTNAME= comonad-transformers
PORTVERSION= 3.0.1
+PORTREVISION= 1
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-comonad/Makefile b/math/hs-comonad/Makefile
index dc29fc0526a5..5719cc6db638 100644
--- a/math/hs-comonad/Makefile
+++ b/math/hs-comonad/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= comonad
-PORTVERSION= 3.0.1.1
+PORTVERSION= 3.0.2
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-comonad/distinfo b/math/hs-comonad/distinfo
index 02bf21e22a82..2a8f812b7bf8 100644
--- a/math/hs-comonad/distinfo
+++ b/math/hs-comonad/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/comonad-3.0.1.1.tar.gz) = 82418cd6783a166e6b9c17040ea1be6b3d0a17b3f55b9f8db3a61bdf71eef807
-SIZE (cabal/comonad-3.0.1.1.tar.gz) = 4302
+SHA256 (cabal/comonad-3.0.2.tar.gz) = 5e3999df99acb4a956b6593718a0aa099c5386fc7f88915c963517d6998bde67
+SIZE (cabal/comonad-3.0.2.tar.gz) = 7660
diff --git a/math/hs-comonads-fd/Makefile b/math/hs-comonads-fd/Makefile
index 060347d9369d..ea1c212a898d 100644
--- a/math/hs-comonads-fd/Makefile
+++ b/math/hs-comonads-fd/Makefile
@@ -2,6 +2,7 @@
PORTNAME= comonads-fd
PORTVERSION= 3.0.1
+PORTREVISION= 1
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-contravariant/Makefile b/math/hs-contravariant/Makefile
index 5883a9326a0d..2c8d500e5d84 100644
--- a/math/hs-contravariant/Makefile
+++ b/math/hs-contravariant/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= contravariant
-PORTVERSION= 0.2.0.2
-PORTREVISION= 3
+PORTVERSION= 0.4
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
@@ -10,7 +9,7 @@ COMMENT= Haskell 98 contravariant functors
LICENSE= BSD
-USE_CABAL= transformers>=0.2.2
+USE_CABAL= tagged>=0.4.4 transformers>=0.3
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/math/hs-contravariant/distinfo b/math/hs-contravariant/distinfo
index 92a8a022957e..16145605d7e0 100644
--- a/math/hs-contravariant/distinfo
+++ b/math/hs-contravariant/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/contravariant-0.2.0.2.tar.gz) = 77b8e9fcc65df51714eb95615b23371aa3bd864e8c6dedb775eb939058d08204
-SIZE (cabal/contravariant-0.2.0.2.tar.gz) = 2929
+SHA256 (cabal/contravariant-0.4.tar.gz) = 8361967a6ee1a3fe113a57242507f56364d8c3daf558370633db74b613a31adb
+SIZE (cabal/contravariant-0.4.tar.gz) = 3277
diff --git a/math/hs-contravariant/files/patch-contravariant.cabal b/math/hs-contravariant/files/patch-contravariant.cabal
new file mode 100644
index 000000000000..8dccf0102fe3
--- /dev/null
+++ b/math/hs-contravariant/files/patch-contravariant.cabal
@@ -0,0 +1,12 @@
+--- ./contravariant.cabal.orig 2013-02-05 23:24:34.000000000 +0100
++++ ./contravariant.cabal 2013-02-10 10:56:13.000000000 +0100
+@@ -25,8 +25,7 @@
+ build-depends:
+ base < 5,
+ tagged >= 0.4.4 && < 1,
+- transformers >= 0.2 && < 0.4,
+- transformers-compat >= 0.1 && < 1
++ transformers >= 0.3 && < 0.4
+ exposed-modules:
+ Data.Functor.Contravariant
+ Data.Functor.Contravariant.Compose
diff --git a/math/hs-data-lens-template/Makefile b/math/hs-data-lens-template/Makefile
index 0d2fbd8c766e..b2cfe132cbdd 100644
--- a/math/hs-data-lens-template/Makefile
+++ b/math/hs-data-lens-template/Makefile
@@ -2,7 +2,7 @@
PORTNAME= data-lens-template
PORTVERSION= 2.1.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-data-lens/Makefile b/math/hs-data-lens/Makefile
index 6c74b09e98a0..c15785b9570b 100644
--- a/math/hs-data-lens/Makefile
+++ b/math/hs-data-lens/Makefile
@@ -2,7 +2,7 @@
PORTNAME= data-lens
PORTVERSION= 2.10.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-distributive/Makefile b/math/hs-distributive/Makefile
index de6f5ef4f374..833163d382e5 100644
--- a/math/hs-distributive/Makefile
+++ b/math/hs-distributive/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= distributive
-PORTVERSION= 0.3
+PORTVERSION= 0.3.1
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-distributive/distinfo b/math/hs-distributive/distinfo
index 05e44530a908..3cbeeb3c357e 100644
--- a/math/hs-distributive/distinfo
+++ b/math/hs-distributive/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/distributive-0.3.tar.gz) = 4e8c782dea78698d7de89e20ddaa4c907ec0e3ba41267d53bf3b242ba6e2db7c
-SIZE (cabal/distributive-0.3.tar.gz) = 5899
+SHA256 (cabal/distributive-0.3.1.tar.gz) = 6c49c36c7c098b3640ff03c3379d766ef23c9914053d671e584ba7df03e6c37d
+SIZE (cabal/distributive-0.3.1.tar.gz) = 5900
diff --git a/math/hs-groupoids/Makefile b/math/hs-groupoids/Makefile
index cf2050cc57af..2ded1df0b287 100644
--- a/math/hs-groupoids/Makefile
+++ b/math/hs-groupoids/Makefile
@@ -2,6 +2,7 @@
PORTNAME= groupoids
PORTVERSION= 3.0.1.1
+PORTREVISION= 1
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-math-functions/Makefile b/math/hs-math-functions/Makefile
index 9139b85d952a..c6d2b9d3872b 100644
--- a/math/hs-math-functions/Makefile
+++ b/math/hs-math-functions/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= math-functions
-PORTVERSION= 0.1.1.2
-PORTREVISION= 1
+PORTVERSION= 0.1.3.0
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-math-functions/distinfo b/math/hs-math-functions/distinfo
index 7c5014508022..32964fffb4d6 100644
--- a/math/hs-math-functions/distinfo
+++ b/math/hs-math-functions/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/math-functions-0.1.1.2.tar.gz) = 3b192313ff99bcdde0fce04de41fafa111e321c424e480223f6feffe0f310927
-SIZE (cabal/math-functions-0.1.1.2.tar.gz) = 16338
+SHA256 (cabal/math-functions-0.1.3.0.tar.gz) = c5abf1f44ef52c30e5dab9675e8fb8605e6568ea356ed1fd9d4f57b81cca9d1b
+SIZE (cabal/math-functions-0.1.3.0.tar.gz) = 23729
diff --git a/math/hs-pointed/Makefile b/math/hs-pointed/Makefile
index 9b4b9f5ad349..e9c3856d54c0 100644
--- a/math/hs-pointed/Makefile
+++ b/math/hs-pointed/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pointed
PORTVERSION= 3.0.2
+PORTREVISION= 1
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-semigroupoid-extras/Makefile b/math/hs-semigroupoid-extras/Makefile
index cf90c8c57d05..ba64da80dd58 100644
--- a/math/hs-semigroupoid-extras/Makefile
+++ b/math/hs-semigroupoid-extras/Makefile
@@ -2,6 +2,7 @@
PORTNAME= semigroupoid-extras
PORTVERSION= 3.0.1
+PORTREVISION= 1
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-semigroupoids/Makefile b/math/hs-semigroupoids/Makefile
index d7af1561f6b7..8e47f38a201b 100644
--- a/math/hs-semigroupoids/Makefile
+++ b/math/hs-semigroupoids/Makefile
@@ -2,6 +2,7 @@
PORTNAME= semigroupoids
PORTVERSION= 3.0.2
+PORTREVISION= 1
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-statistics/Makefile b/math/hs-statistics/Makefile
index 895ac101efe8..985dc499bb6d 100644
--- a/math/hs-statistics/Makefile
+++ b/math/hs-statistics/Makefile
@@ -3,7 +3,7 @@
PORTNAME= statistics
PORTVERSION= 0.10.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-vector-space/Makefile b/math/hs-vector-space/Makefile
index 8ba80b0aff24..14f81263fc53 100644
--- a/math/hs-vector-space/Makefile
+++ b/math/hs-vector-space/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vector-space
PORTVERSION= 0.8.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org