aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/qtiplot/Makefile10
-rw-r--r--math/qtiplot/distinfo6
-rw-r--r--math/qtiplot/files/patch-qtiplot.pro6
-rw-r--r--math/qtiplot/files/patch-qtiplot__qtiplot.pro17
-rw-r--r--math/qtiplot/pkg-plist1
5 files changed, 14 insertions, 26 deletions
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index 6422cabed838..a5068679bc73 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qtiplot
-DISTVERSION= 0.9.5
+DISTVERSION= 0.9.6
CATEGORIES= math science
MASTER_SITES= http://soft.proindependent.com/src/
@@ -23,7 +23,7 @@ USE_GMAKE= yes
USE_QT_VER= 4
QT_COMPONENTS= gui moc_build qmake_build opengl svg qt3support network assistantclient
HAS_CONFIGURE= yes
-CONFIGURE_ENV+= LOCALBASE="${LOCALBASE}"
+QMAKE_ARGS+= -unix -recursive LOCALBASE=${LOCALBASE}
USE_DOS2UNIX= *.pro
MAN1= qtiplot.1
@@ -65,9 +65,6 @@ PLIST_SUB+= NLS="@comment "
post-patch:
.if defined(WITH_PYTHON)
@${REINPLACE_CMD} -e \
- 's|loadInitFile("qtiplotrc")|loadInitFile("${DATADIR}/qtiplotrc")|' \
- ${WRKSRC}/${PORTNAME}/src/PythonScripting.cpp
- @${REINPLACE_CMD} -e \
'/^sys.path.append/s|"\."|"${DATADIR}"|' \
${WRKSRC}/${PORTNAME}/qtiplotrc.py
@${REINPLACE_CMD} -e \
@@ -91,7 +88,7 @@ do-configure:
.if !defined(WITHOUT_NLS)
@(cd ${WRKSRC}/qtiplot && ${LOCALBASE}/bin/lrelease-qt4 qtiplot.pro)
.endif
- @(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} -recursive)
+ @(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKE_ARGS})
post-configure:
@${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} -e \
@@ -109,6 +106,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fitPlugins/libfitRational1.so.1.0.0 \
${DATADIR}/fitPlugins/libfitRational1.so
${INSTALL_DATA} ${WRKSRC}/qtiplot_logo.png ${DATADIR}/qtiplot.png
+ ${INSTALL_DATA} ${WRKSRC}/qtiplot/qti_wordlist.txt ${DATADIR}
.if defined(WITH_PYTHON)
.for s in qtiplotrc.py qtiUtil.py
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/${s} ${DATADIR}/${s}
diff --git a/math/qtiplot/distinfo b/math/qtiplot/distinfo
index 56d9a6128273..f3bbc38b4c9e 100644
--- a/math/qtiplot/distinfo
+++ b/math/qtiplot/distinfo
@@ -1,3 +1,3 @@
-MD5 (qtiplot-0.9.5.tar.bz2) = 5e321e8b2fb4d9eb3f5f8703afdb84ae
-SHA256 (qtiplot-0.9.5.tar.bz2) = 29f6f0b81ee02fa64db2f1024d3fafeedcf22ae498eadef04e5092371d1e3be2
-SIZE (qtiplot-0.9.5.tar.bz2) = 7047424
+MD5 (qtiplot-0.9.6.tar.bz2) = a0e35d674fdf76eeb86c921e26caec1a
+SHA256 (qtiplot-0.9.6.tar.bz2) = 9892f48eaf08f7e9f9932156c755a37a3570f5028e1777263706cd1fb688c7c1
+SIZE (qtiplot-0.9.6.tar.bz2) = 6431763
diff --git a/math/qtiplot/files/patch-qtiplot.pro b/math/qtiplot/files/patch-qtiplot.pro
index 54be526976aa..3e0e5c8373b6 100644
--- a/math/qtiplot/files/patch-qtiplot.pro
+++ b/math/qtiplot/files/patch-qtiplot.pro
@@ -1,9 +1,9 @@
---- ./qtiplot.pro.orig 2008-03-29 10:43:50.000000000 +0300
-+++ ./qtiplot.pro 2008-03-29 10:43:50.000000000 +0300
+--- ./qtiplot.pro.orig 2008-04-20 19:16:15.000000000 +0400
++++ ./qtiplot.pro 2008-04-20 19:18:10.000000000 +0400
@@ -2,6 +2,4 @@
SUBDIRS = fitPlugins/fitRational0\
fitPlugins/fitRational1\
- 3rdparty/qwt\
-- manual\
+- manual\
qtiplot
diff --git a/math/qtiplot/files/patch-qtiplot__qtiplot.pro b/math/qtiplot/files/patch-qtiplot__qtiplot.pro
index 95cffabe7050..d390ab26964c 100644
--- a/math/qtiplot/files/patch-qtiplot__qtiplot.pro
+++ b/math/qtiplot/files/patch-qtiplot__qtiplot.pro
@@ -10,8 +10,8 @@
-INCLUDEPATH += ../3rdparty/liborigin
-INCLUDEPATH += ../3rdparty/gsl/include
-INCLUDEPATH += ../3rdparty/zlib123/include
-+unix:INCLUDEPATH += $$(LOCALBASE)/include/qwt
-+unix:INCLUDEPATH += $$(LOCALBASE)/include/qwtplot3d-qt4
++unix:INCLUDEPATH += $$LOCALBASE/include/qwt
++unix:INCLUDEPATH += $$LOCALBASE/include/qwtplot3d-qt4
##################### 3rd PARTY LIBRARIES SECTION ###########################
#!!! Warning: You must modify these paths according to your computer settings
@@ -32,21 +32,10 @@
-#unix:LIBS += -lgsl -lgslcblas
+unix:LIBS += -lqwt
+unix:LIBS += -lgsl -lgslcblas
-+unix:LIBS += -L$$(LOCALBASE)/lib -lqwtplot3d-qt4 -lz
++unix:LIBS += -L$$LOCALBASE/lib -lqwtplot3d-qt4 -lz
##################### Windows ###############################################
-@@ -124,8 +116,8 @@
- translations/qtiplot_ja.ts \
- translations/qtiplot_sv.ts
-
--system(lupdate -verbose qtiplot.pro)
--system(lrelease -verbose qtiplot.pro)
-+#system(lupdate -verbose qtiplot.pro)
-+#system(lrelease -verbose qtiplot.pro)
-
- translations.files += translations/qtiplot_de.qm \
- translations/qtiplot_es.qm \
@@ -435,6 +427,7 @@
##################### Default: muParser v1.28 #################
diff --git a/math/qtiplot/pkg-plist b/math/qtiplot/pkg-plist
index 1632732b152f..f90aa6d62b23 100644
--- a/math/qtiplot/pkg-plist
+++ b/math/qtiplot/pkg-plist
@@ -1,6 +1,7 @@
bin/qtiplot
%%DATADIR%%/fitPlugins/libfitRational0.so
%%DATADIR%%/fitPlugins/libfitRational1.so
+%%DATADIR%%/qti_wordlist.txt
%%DATADIR%%/qtiplot
%%DATADIR%%/qtiplot.png
%%PYTHON%%%%DATADIR%%/qtiUtil.py