aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/octave-forge-odepkg/Makefile7
-rw-r--r--math/octave-forge-odepkg/distinfo4
-rw-r--r--math/octave-forge-odepkg/files/patch-Makefile11
3 files changed, 17 insertions, 5 deletions
diff --git a/math/octave-forge-odepkg/Makefile b/math/octave-forge-odepkg/Makefile
index 325e9513453b..a526aeb5f58e 100644
--- a/math/octave-forge-odepkg/Makefile
+++ b/math/octave-forge-odepkg/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= octave-forge-odepkg
-PORTVERSION= 0.8.4
-PORTREVISION= 4
+PORTVERSION= 0.8.5
CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
@@ -12,11 +11,13 @@ COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
LICENSE= GPLv2
LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+BUILD_DEPENDS= gpatch:${PORTSDIR}/devel/patch
+
MAKE_JOBS_UNSAFE= yes
# OCTSRC is the name of the directory of the package.
# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
-OCTSRC= ${OCTAVE_PKGNAME}
+OCTSRC= ${DISTNAME}
WRKSRC= ${WRKDIR}/${OCTSRC}/src
diff --git a/math/octave-forge-odepkg/distinfo b/math/octave-forge-odepkg/distinfo
index a927df62bfdc..21f6d3d2d03f 100644
--- a/math/octave-forge-odepkg/distinfo
+++ b/math/octave-forge-odepkg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (octave-forge/odepkg-0.8.4.tar.gz) = 77e99f082712c78ca4bcce389b786a6c8a546d0dc3b89bcced544518eb492cb8
-SIZE (octave-forge/odepkg-0.8.4.tar.gz) = 530740
+SHA256 (octave-forge/odepkg-0.8.5.tar.gz) = ad0e1e7f91a9d6b711ddd2d17c9135f4009417b1429d294a0a03765e21e8a288
+SIZE (octave-forge/odepkg-0.8.5.tar.gz) = 437252
diff --git a/math/octave-forge-odepkg/files/patch-Makefile b/math/octave-forge-odepkg/files/patch-Makefile
new file mode 100644
index 000000000000..c654e6a571bd
--- /dev/null
+++ b/math/octave-forge-odepkg/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile-orig 2015-05-21 17:31:08.336670000 +0000
++++ Makefile 2015-05-21 17:31:18.556578000 +0000
+@@ -5,7 +5,7 @@
+
+ DEVELOPERDEFS = -Wall -W -Wshadow
+ TGZUNPACK = tar -xzf # "tar -xzvf" to print some output
+-PATCHPROG = patch -p0 # Needed to patch the Fortran codes
++PATCHPROG = gpatch -p0 # Needed to patch the Fortran codes
+
+ # MKOCTFILE = $(MKOCTFILE) has already been defined in Makeconf
+ # MKMEXFILE = $(MKOCTFILE) --mex