aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/asymptote/Makefile4
-rw-r--r--math/digitizer/Makefile4
-rw-r--r--math/fftw3-float/Makefile4
-rw-r--r--math/fftw3-long/Makefile4
-rw-r--r--math/fftw3/Makefile87
-rw-r--r--math/fftw3/distinfo4
-rw-r--r--math/fftw3/pkg-plist9
-rw-r--r--math/freemat/Makefile6
-rw-r--r--math/gretl/Makefile4
-rw-r--r--math/labplot/Makefile4
-rw-r--r--math/octave-devel/Makefile4
-rw-r--r--math/octave/Makefile4
-rw-r--r--math/ruby-fftw3/Makefile4
-rw-r--r--math/scilab/Makefile3
14 files changed, 80 insertions, 65 deletions
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index 04b9d01f236c..65a98de00c0a 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asymptote
PORTVERSION= 2.04
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION} \
SF/${PORTNAME}/${PORTNAME}/old/${PORTVERSION}
@@ -21,7 +21,7 @@ COMMENT= A powerful script-based vector graphics language
LIB_DEPENDS+= gsl.16:${PORTSDIR}/math/gsl
.endif
.if defined(WITH_FFTW)
-LIB_DEPENDS= fftw3.5:${PORTSDIR}/math/fftw3
+LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3
.endif
BUILD_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
dvips:${PORTSDIR}/print/dvipsk-tetex \
diff --git a/math/digitizer/Makefile b/math/digitizer/Makefile
index c1885d028ca3..8131a2b797ef 100644
--- a/math/digitizer/Makefile
+++ b/math/digitizer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= digitizer
PORTVERSION= 4.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= math graphics
MASTER_SITES= SF/${PORTNAME}/Engauge%20Digitizer/${PORTNAME}-${PORTVERSION}
DISTNAME= digit-src-${PORTVERSION:S/./_/}
@@ -16,7 +16,7 @@ MAINTAINER= thierry@FreeBSD.org
COMMENT= Engauge Digitizer - Digitizing software to convert graphs into numbers
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
-LIB_DEPENDS= fftw3.5:${PORTSDIR}/math/fftw3
+LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3
WRKSRC= ${WRKDIR}/engauge
diff --git a/math/fftw3-float/Makefile b/math/fftw3-float/Makefile
index 635c48f48055..ad3329b43333 100644
--- a/math/fftw3-float/Makefile
+++ b/math/fftw3-float/Makefile
@@ -5,9 +5,7 @@
# $FreeBSD$
# $MCom: ports-experimental/math/fftw3-float/Makefile,v 1.1 2006/03/28 00:08:57 ahze Exp $
-PORTREVISION= 2
-
-COMMENT= Fast C routines (Single Precision)
+COMMENT= Fast Discrete Fourier Transform (Single Precision C Routines)
FFTW3_FLAVOR= float
MASTERDIR= ${.CURDIR}/../../math/fftw3
diff --git a/math/fftw3-long/Makefile b/math/fftw3-long/Makefile
index ab90ea52f28d..f8d676ff94f1 100644
--- a/math/fftw3-long/Makefile
+++ b/math/fftw3-long/Makefile
@@ -5,9 +5,7 @@
# $FreeBSD$
# $MCom: ports-experimental/math/fftw3-long/Makefile,v 1.1 2006/03/28 00:08:58 ahze Exp $
-PORTREVISION= 1
-
-COMMENT= Fast C routines (Long Double Precision)
+COMMENT= Fast Discrete Fourier Transform (Long Double Precision C Routines)
FFTW3_FLAVOR= long
MASTERDIR= ${.CURDIR}/../../math/fftw3
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index 1a2f79e8011c..e911ace117d5 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -6,8 +6,7 @@
# $MCom: ports-experimental/math/fftw3/Makefile,v 1.1 2006/03/28 00:08:57 ahze Exp $
PORTNAME= fftw3
-PORTVERSION= 3.2.2
-PORTREVISION?= 1
+PORTVERSION= 3.3
CATEGORIES= math
MASTER_SITES= ftp://ftp.fftw.org/pub/fftw/ \
ftp://ftp.fftw.org/pub/fftw/old/
@@ -26,19 +25,23 @@ USE_GNOME= gnomehack pkgconfig
USE_PERL5_BUILD=yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --enable-shared --enable-threads
-CPPFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CONFIGURE_ARGS = --enable-openmp --enable-shared --enable-threads \
+ --disable-fortran
+CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
.if ${FFTW3_FLAVOR} == "default"
MAN1= fftw-wisdom-to-conf.1 fftw-wisdom.1
INFO= fftw3
.else
+#For non-default flavors, only build and install the flavor-dependent components,
+#so that these flavors may coexist with the default flavor
MAN1= fftw${FFTW3_SUFX}-wisdom.1
INSTALL_TARGET= install-pkgconfigDATA install-libLTLIBRARIES install-exec
.endif
-OPTIONS= OPTIMIZED_CFLAGS "Enable optimized CFLAGS" off
+OPTIONS= G77_WRAPPERS "Alter Fortran wrappers for use with g77" off \
+ OPTIMIZED_CFLAGS "Enable optimized CFLAGS" on
.include <bsd.port.pre.mk>
@@ -47,34 +50,27 @@ CFLAGS+= -O3 -ffast-math -fstrict-aliasing
. if !defined(WITH_DEBUG)
CFLAGS+= -fomit-frame-pointer
. endif
-. if empty(CC:Mclang)
-CODELET_OPTIM += -fno-schedule-insns -fno-web -fno-loop-optimize \
- --param inline-unit-growth=1000 \
- --param large-function-growth=1000
-. endif
. if ${ARCH} == "i386"
CFLAGS+= -malign-double
-CODELET_OPTIM += -O
. endif
-CONFIGURE_ENV += CODELET_OPTIM="${CODELET_OPTIM}"
WITHOUT_NO_STRICT_ALIASING= yes
-. if !empty(MACHINE_CPU:Msse2) && ${FFTW3_FLAVOR} == "default"
-CONFIGURE_ARGS+=--enable-sse2
-. elif ${FFTW3_FLAVOR} == "float"
-. if !empty(MACHINE_CPU:Msse)
-CONFIGURE_ARGS+=--enable-sse
-. elif !empty(ARCH:Mpowerpc*)
-#users should set ALTIVEC_ARG to be empty if sysctl hw.altivec = 0 on the target machine
-ALTIVEC_ARG?= --enable-altivec
-CONFIGURE_ARGS+= ${ALTIVEC_ARG}
-. endif
-. endif
.endif # end WITH_OPTIMIZED_CFLAGS
-.if ${FFTW3_FLAVOR} == "float"
+.if ${FFTW3_FLAVOR} == "default"
+. if !empty(MACHINE_CPU:Msse2)
+CONFIGURE_ARGS+=--enable-sse2
+. endif
+.elif ${FFTW3_FLAVOR} == "float"
FFTW3_SUFX= f
FFTW3_PKGNAMESUFFIX= -float
CONFIGURE_ARGS+=--enable-float
+. if !empty(MACHINE_CPU:Msse)
+CONFIGURE_ARGS+=--enable-sse
+#Unfortunately, the user must add altivec to MACHINE_CPU when desired,
+#because this is not currently done in bsd.cpu.mk
+. elif !empty(ARCH:Mpowerpc*) && !empty(MACHINE_CPU:Maltivec)
+CONFIGURE_ARGS+=--enable-altivec
+. endif
.elif ${FFTW3_FLAVOR} == "long"
. if ${OSVERSION} < 800000
ONLY_FOR_ARCHS = i386 sparc64
@@ -83,6 +79,12 @@ LIB_DEPENDS+= ml.0:${PORTSDIR}/math/ldouble
FFTW3_SUFX= l
FFTW3_PKGNAMESUFFIX= -long
CONFIGURE_ARGS+=--enable-long-double
+.elif ${FFTW3_FLAVOR} == "quad"
+FFTW3_SUFX= q
+FFTW3_PKGNAMESUFFIX= -quad
+CONFIGURE_ARGS+=--enable-quad-precision
+ONLY_FOR_ARCHS = i386 amd64
+USE_GCC= 4.6+
.endif
.if ${FFTW3_FLAVOR} == "default"
@@ -102,30 +104,41 @@ post-patch:
${WRKSRC}/tools/*
@${FIND} ${WRKSRC} -name \*.bak -type f -exec ${RM} -f {} \;
.if ${FFTW3_FLAVOR} != "default"
- @${REINPLACE_CMD} -e \
- 's|EXTRA_DIST = fftw-wisdom-to-conf.in||; \
- s|fftw-wisdom-to-conf.in||; \
- s|fftw-wisdom-to-conf: $(top_builddir)/config.status||; \
- s|bin_SCRIPTS = fftw-wisdom-to-conf||' \
+ @${REINPLACE_CMD} -E -e \
+ '/(DIST_COMMON|bin_SCRIPTS|BUILT_SOURCES|EXTRA_DIST) =/,\
+ /[^\]$$/s/[^[:blank:]]*fftw-wisdom-to-conf[^[:blank:]]*//' \
${WRKSRC}/tools/Makefile.in
. if ${FFTW3_FLAVOR} == "long" && ${OSVERSION} < 800000
@${REINPLACE_CMD} -e 's|cosl sinl tanl||' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -E -e \
- 's|@LIBS@|-lml @LIBS@|'
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|@LIBS@|-L${LOCALBASE}/lib -lml &|'
. endif
.endif
post-configure:
- @echo "#define F77_FUNC(name,NAME) name ## _" >>${WRKSRC}/config.h
- @echo "#define F77_FUNC_(name,NAME) name ## _" >>${WRKSRC}/config.h
- @echo "#define F77_FUNC_EQUIV 1" >>${WRKSRC}/config.h
+#After issuing --disable-fortran in order to avoid using a Fortran compiler
+#during configuration, edit config.h to provide Fortran wrappers appropriate for
+#gfortran, with ac_cv_f77_mangling="lower case, underscore, no extra underscore"
+ @${REINPLACE_CMD} -e '/DISABLE_FORTRAN/d' ${WRKSRC}/config.h
+ @${ECHO_CMD} "#define F77_FUNC(name,NAME) name ## _" >> ${WRKSRC}/config.h
+ @${ECHO_CMD} "#define F77_FUNC_(name,NAME) name ## _" >> ${WRKSRC}/config.h
+ @${ECHO_CMD} "#define F77_FUNC_EQUIV 1" >> ${WRKSRC}/config.h
+.if defined(WITH_G77_WRAPPERS)
+ @${ECHO_CMD} "#define WITH_G77_WRAPPERS 1" >> ${WRKSRC}/config.h
+.endif
.if ${FFTW3_FLAVOR} != "default"
post-install:
@${INSTALL_MAN} ${WRKSRC}/tools/fftw${FFTW3_SUFX}-wisdom.1 ${PREFIX}/man/man1
.endif
-check regression-test test: build
- @cd ${WRKSRC}/tests && ${SETENV} ${MAKE_ENV} ${MAKE} smallcheck
+regression-test test: smallcheck
+
+.for t in bigcheck check exhaustive-check paranoid-check smallcheck
+${t}: build
+ @cd ${WRKSRC}/tests; ${SETENV} ${MAKE_ENV} ${MAKE} ${_MAKE_JOBS} \
+ ${MAKE_ARGS} ${t}
+
+.endfor
.include <bsd.port.post.mk>
diff --git a/math/fftw3/distinfo b/math/fftw3/distinfo
index def3668d1380..c8b925f8fb69 100644
--- a/math/fftw3/distinfo
+++ b/math/fftw3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fftw-3.2.2.tar.gz) = 6aa7ae65ee49eb99004f15899f9bb77f54759122f1a350041e81e096157d768f
-SIZE (fftw-3.2.2.tar.gz) = 3495117
+SHA256 (fftw-3.3.tar.gz) = d25a98521a13933e678ce19319d03ddc915826764e1e59abd12d172c239b6aea
+SIZE (fftw-3.3.tar.gz) = 3965713
diff --git a/math/fftw3/pkg-plist b/math/fftw3/pkg-plist
index 4b7967b27056..06ac6afadfa1 100644
--- a/math/fftw3/pkg-plist
+++ b/math/fftw3/pkg-plist
@@ -1,13 +1,18 @@
bin/fftw%%FFTW3_SUFX%%-wisdom
%%DEF%%bin/fftw-wisdom-to-conf
%%DEF%%include/fftw3.f
+%%DEF%%include/fftw3.f03
%%DEF%%include/fftw3.h
lib/libfftw3%%FFTW3_SUFX%%.a
lib/libfftw3%%FFTW3_SUFX%%.la
lib/libfftw3%%FFTW3_SUFX%%.so
-lib/libfftw3%%FFTW3_SUFX%%.so.5
+lib/libfftw3%%FFTW3_SUFX%%.so.6
+lib/libfftw3%%FFTW3_SUFX%%_omp.a
+lib/libfftw3%%FFTW3_SUFX%%_omp.la
+lib/libfftw3%%FFTW3_SUFX%%_omp.so
+lib/libfftw3%%FFTW3_SUFX%%_omp.so.6
lib/libfftw3%%FFTW3_SUFX%%_threads.a
lib/libfftw3%%FFTW3_SUFX%%_threads.la
lib/libfftw3%%FFTW3_SUFX%%_threads.so
-lib/libfftw3%%FFTW3_SUFX%%_threads.so.5
+lib/libfftw3%%FFTW3_SUFX%%_threads.so.6
libdata/pkgconfig/fftw3%%FFTW3_SUFX%%.pc
diff --git a/math/freemat/Makefile b/math/freemat/Makefile
index 1fd0a783a65f..2a61f0605ed4 100644
--- a/math/freemat/Makefile
+++ b/math/freemat/Makefile
@@ -8,7 +8,7 @@
PORTNAME= FreeMat
PORTVERSION= 4.0
DISTVERSIONSUFFIX= -Source
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math science
MASTER_SITES= SF
MASTER_SITE_SUBDIR= freemat/FreeMat4
@@ -46,8 +46,8 @@ SLAVEDIRS= math/freemat-mpi
DATADIR+= ${PREFIX}/share/${PORTNAME}-${PORTVERSION}
.if !defined(WITHOUT_FFTW)
-LIB_DEPENDS+= fftw3.5:${PORTSDIR}/math/fftw3 \
- fftw3f.5:${PORTSDIR}/math/fftw3-float
+LIB_DEPENDS+= fftw3:${PORTSDIR}/math/fftw3 \
+ fftw3f:${PORTSDIR}/math/fftw3-float
.endif
.if !defined(WITHOUT_ARPACK)
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index d75efd05662c..9336eb5c9c20 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -8,14 +8,14 @@
PORTNAME= gretl
PORTVERSION= 1.9.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math finance
MASTER_SITES= SF
MAINTAINER= bf@FreeBSD.org
COMMENT= GNU Regression, Econometrics and Time-series Library
-LIB_DEPENDS= fftw3.5:${PORTSDIR}/math/fftw3
+LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3
GNU_CONFIGURE= yes
USE_BZIP2= yes
diff --git a/math/labplot/Makefile b/math/labplot/Makefile
index 2ea79f03f9c7..d265ba4783e6 100644
--- a/math/labplot/Makefile
+++ b/math/labplot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= LabPlot
PORTVERSION= 1.6.0.2
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= math kde
MASTER_SITES= SF
@@ -18,7 +18,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
jasper.4:${PORTSDIR}/graphics/jasper \
MagickWand.5:${PORTSDIR}/graphics/ImageMagick \
gsl.16:${PORTSDIR}/math/gsl \
- fftw3.5:${PORTSDIR}/math/fftw3 \
+ fftw3:${PORTSDIR}/math/fftw3 \
qwtplot3d.0:${PORTSDIR}/math/qwtplot3d \
origin.0:${PORTSDIR}/math/liborigin
diff --git a/math/octave-devel/Makefile b/math/octave-devel/Makefile
index 05677b52ad25..e25a7cfe5e67 100644
--- a/math/octave-devel/Makefile
+++ b/math/octave-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= octave
PORTVERSION= 3.3.50
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= math
MASTER_SITES= ftp://ftp.octave.org/pub/octave/bleeding-edge/ \
ftp://ftp.eos.hokudai.ac.jp/pub/GNU/misc/octave/bleeding-edge/\
@@ -24,7 +24,7 @@ BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot \
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
gsed:${PORTSDIR}/textproc/gsed
LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
- glpk.30:${PORTSDIR}/math/glpk \
+ glpk.32:${PORTSDIR}/math/glpk \
hdf5:${PORTSDIR}/science/hdf5 \
umfpack.1:${PORTSDIR}/math/suitesparse \
qhull.5:${PORTSDIR}/math/qhull5
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 836db212414b..50c46539d74c 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -7,7 +7,7 @@
PORTNAME= octave
PORTVERSION= 3.4.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= ftp://ftp.gnu.org/gnu/octave/ \
ftp://ftp.u-aizu.ac.jp/pub/SciEng/numanal/Octave/bleeding-edge/
@@ -35,7 +35,7 @@ LIB_DEPENDS= GraphicsMagick.1:${PORTSDIR}/graphics/GraphicsMagick \
qhull.5:${PORTSDIR}/math/qhull5 \
qrupdate:${PORTSDIR}/math/qrupdate \
umfpack.1:${PORTSDIR}/math/suitesparse \
- glpk.30:${PORTSDIR}/math/glpk
+ glpk.32:${PORTSDIR}/math/glpk
USE_BZIP2= yes
USE_PERL5_BUILD=yes
diff --git a/math/ruby-fftw3/Makefile b/math/ruby-fftw3/Makefile
index acc4939cf356..038ab1944246 100644
--- a/math/ruby-fftw3/Makefile
+++ b/math/ruby-fftw3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fftw3
PORTVERSION= 0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math ruby
MASTER_SITES= http://ruby.gfd-dennou.org/products/ruby-fftw3/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -18,7 +18,7 @@ MAINTAINER= murashin@gfd-dennou.org
COMMENT= A Ruby interface to the FFTW ver.3
BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray
-LIB_DEPENDS= fftw3.5:${PORTSDIR}/math/fftw3
+LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index 8f0f1c808c38..3b03dcbc038c 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -7,6 +7,7 @@
PORTNAME= scilab
PORTVERSION= 5.3.3
+PORTREVISION= 1
CATEGORIES= math cad parallel java
MASTER_SITES= http://www.scilab.org/download/${PORTVERSION}/:scilab \
http://www.predatorlabs.net/dl/:jgraphx \
@@ -146,7 +147,7 @@ ALL_TARGET= all doc
.if defined(WITHOUT_FFTW)
CONFIGURE_ARGS+= --without-fftw
.else
-LIB_DEPENDS+= fftw3.5:${PORTSDIR}/math/fftw3
+LIB_DEPENDS+= fftw3:${PORTSDIR}/math/fftw3
.endif
.if defined(WITHOUT_PVM)