aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/calcoo/Makefile2
-rw-r--r--math/fftw3/Makefile3
-rw-r--r--math/freemat/Makefile9
-rw-r--r--math/libqalculate/Makefile2
-rw-r--r--math/py-matplotlib/Makefile2
-rw-r--r--math/wfmath/Makefile3
6 files changed, 7 insertions, 14 deletions
diff --git a/math/calcoo/Makefile b/math/calcoo/Makefile
index 43aa9fd3e77f..c3d74b35ec12 100644
--- a/math/calcoo/Makefile
+++ b/math/calcoo/Makefile
@@ -9,8 +9,8 @@ MASTER_SITES= SF
MAINTAINER= naddy@FreeBSD.org
COMMENT= RPN and algebraic scientific calculator
+USES= pkgconfig
USE_GNOME= gtk20
-USE_PKGCONFIG= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index 9fafb2925de5..e69d25bb5626 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -19,10 +19,9 @@ FFTW3_FLAVOR?= default
FFTW3_SUFX=
GNU_CONFIGURE= yes
-USES= pathfix
+USES= pathfix pkgconfig
USE_PERL5_BUILD=yes
USE_LDCONFIG= yes
-USE_PKGCONFIG= yes
CONFIGURE_ARGS = --enable-shared --enable-threads --disable-fortran
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
diff --git a/math/freemat/Makefile b/math/freemat/Makefile
index 134c01580079..cd5b3dc02a63 100644
--- a/math/freemat/Makefile
+++ b/math/freemat/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: FreeMat
-# Date created: Sat 26 mar 2005
-# Whom: Thierry Thomas <thierry@pompo.net>
-#
+# Created by: Thierry Thomas <thierry@pompo.net>
# $FreeBSD$
-#
PORTNAME= FreeMat
PORTVERSION= 4.0
@@ -34,8 +30,7 @@ USE_FORTRAN= yes
FFLAGS+= -O2
USE_GL= yes
-USE_PKGCONFIG= yes
-USES= cmake
+USES= cmake pkgconfig
USE_QT4= gui network opengl moc_build rcc_build uic_build \
qmake_build xml svg
CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include ${AMDINC}
diff --git a/math/libqalculate/Makefile b/math/libqalculate/Makefile
index 899a43802831..16b58cd0033a 100644
--- a/math/libqalculate/Makefile
+++ b/math/libqalculate/Makefile
@@ -12,7 +12,7 @@ COMMENT= Multi-purpose desktop calculator (backend library)
LIB_DEPENDS= cln:${PORTSDIR}/math/cln
-USE_PKGCONFIG= build
+USES= pkgconfig
USE_GNOME= glib20 gnomehack intlhack libxml2
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index 7cc1ec315aee..a4cc7132d818 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
png15:${PORTSDIR}/graphics/png
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PKGCONFIG= build
+USES= pkgconfig
USE_PYTHON= yes
USE_PYDISTUTILS=yes
CFLAGS+= -I${LOCALBASE}/include
diff --git a/math/wfmath/Makefile b/math/wfmath/Makefile
index 0226fb6e3ce7..ad1a22690ec0 100644
--- a/math/wfmath/Makefile
+++ b/math/wfmath/Makefile
@@ -10,8 +10,7 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= Worldforge math library
USE_GMAKE= yes
-USES= pathfix
-USE_PKGCONFIG= yes
+USES= pathfix pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes