aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/acalc/Makefile2
-rw-r--r--math/clblas/Makefile2
-rw-r--r--math/gap/Makefile5
-rw-r--r--math/reduce/Makefile2
4 files changed, 9 insertions, 2 deletions
diff --git a/math/acalc/Makefile b/math/acalc/Makefile
index ac9105cfa854..20c9349db46d 100644
--- a/math/acalc/Makefile
+++ b/math/acalc/Makefile
@@ -10,6 +10,8 @@ COMMENT= Simple and pretty Qt4-based expression calculator
LICENSE= BSD4CLAUSE
+BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++11"
+
USE_GITHUB= yes
GH_ACCOUNT= anpp
diff --git a/math/clblas/Makefile b/math/clblas/Makefile
index 0024cf54b8e2..5d8ab222be2b 100644
--- a/math/clblas/Makefile
+++ b/math/clblas/Makefile
@@ -18,6 +18,8 @@ LIB_DEPENDS= libOpenCL.so:devel/ocl-icd \
libboost_program_options.so:devel/boost-libs
RUN_DEPENDS= opencl>=0:devel/opencl
+BROKEN_powerpc64= fails to compile: xgemm.cc: error: extra ';'
+
USE_GITHUB= yes
GH_ACCOUNT= clMathLibraries
GH_PROJECT= clBLAS
diff --git a/math/gap/Makefile b/math/gap/Makefile
index adc7824b4b0c..af79ecc7cb5f 100644
--- a/math/gap/Makefile
+++ b/math/gap/Makefile
@@ -17,6 +17,9 @@ LICENSE= GPLv2+
LIB_DEPENDS= libgmp.so:math/gmp
+BROKEN_aarch64= fails to link: undefined reference to SyAllocBags
+BROKEN_powerpc64= fails to package: 2_manifolds_54.scb: No such file or directory
+
USES= gmake shebangfix tar:bzip2
SHEBANG_FILES= configure \
pkg/GAPDoc-*/*/clean \
@@ -42,8 +45,6 @@ GAP_LIBDIR= ${PREFIX}/lib/${GAP_VERSION}
WRKSRC= ${WRKDIR}/${GAP_VERSION}
PLIST_FILES= bin/gap
-BROKEN_aarch64= Fails to link: undefined reference to SyAllocBags
-
post-patch:
@${REINPLACE_CMD} -i '' -e '1s|/usr/bin/sh|/bin/sh|' \
${WRKSRC}/pkg/happrime/make_tarball
diff --git a/math/reduce/Makefile b/math/reduce/Makefile
index 58f461ce72f0..a2c2bfd3aafd 100644
--- a/math/reduce/Makefile
+++ b/math/reduce/Makefile
@@ -14,6 +14,8 @@ LICENSE= BSD2CLAUSE
RUN_DEPENDS= gnuplot:math/gnuplot
+BROKEN_powerpc64= fails to compile: arith01.cpp: 'statuc' does not name a type
+
USES= autoreconf:build gmake libtool ncurses
TARGET_SDIR= ${ARCH:S/amd64/x86_64/}-unknown-${OPSYS:tl}${OSREL}
CONFIGURE_ARGS= --build=${TARGET_SDIR}