aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/givaro/Makefile2
-rw-r--r--math/gmp-ecm/Makefile2
-rw-r--r--math/igraph/Makefile2
-rw-r--r--math/lapack95/Makefile6
-rw-r--r--math/ocamlgsl/Makefile2
-rw-r--r--math/octave-forge-dicom/Makefile2
-rw-r--r--math/octave-forge-gsl/Makefile2
-rw-r--r--math/octave-forge-ltfat/Makefile6
-rw-r--r--math/octave-forge-octproj/Makefile2
-rw-r--r--math/octave-forge-symbolic/Makefile2
-rw-r--r--math/octave-forge-video/Makefile2
-rw-r--r--math/orpie/Makefile2
-rw-r--r--math/petsc/Makefile2
-rw-r--r--math/ploticus/Makefile8
-rw-r--r--math/py-gmpy/Makefile2
-rw-r--r--math/py-gsl/Makefile2
-rw-r--r--math/ruby-gsl/Makefile2
-rw-r--r--math/scalapack/Makefile8
-rw-r--r--math/sdpa-gmp/Makefile6
-rw-r--r--math/sdpa/Makefile10
-rw-r--r--math/sdpara/Makefile14
-rw-r--r--math/superlu/Makefile6
-rw-r--r--math/timbl/Makefile3
23 files changed, 47 insertions, 48 deletions
diff --git a/math/givaro/Makefile b/math/givaro/Makefile
index 248b2fba8772..01255895032a 100644
--- a/math/givaro/Makefile
+++ b/math/givaro/Makefile
@@ -14,7 +14,7 @@ LICENSE_NAME= Ce[a] C[nrs] I[nria] L[ogiciel] L[ibre] B license, version 1
LICENSE_FILE= ${WRKSRC}/Licence_CeCILL-B_V1-en.txt
LICENSE_PERMS= auto-accept
-LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
GNU_CONFIGURE= yes
CONFIGURE_ARGS = --with-gmp="${LOCALBASE}"
diff --git a/math/gmp-ecm/Makefile b/math/gmp-ecm/Makefile
index 726aedc3e002..8a6546a45630 100644
--- a/math/gmp-ecm/Makefile
+++ b/math/gmp-ecm/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ecm-${PORTVERSION}
MAINTAINER= culot@FreeBSD.org
COMMENT= Elliptic Curve Method for Integer Factorization
-LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
diff --git a/math/igraph/Makefile b/math/igraph/Makefile
index 603e84395a15..b792172cac5b 100644
--- a/math/igraph/Makefile
+++ b/math/igraph/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF/${PORTNAME}/C%20library/${PORTVERSION}
MAINTAINER= wen@FreeBSD.org
COMMENT= Package For Manipulating Undirected And Directed Graphs
-LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
GNU_CONFIGURE= yes
USE_GCC= any
diff --git a/math/lapack95/Makefile b/math/lapack95/Makefile
index 29311369fc77..05d4cc723054 100644
--- a/math/lapack95/Makefile
+++ b/math/lapack95/Makefile
@@ -35,12 +35,12 @@ WITH_BLAS?= reference
.endif
.if ${WITH_BLAS} == atlas
-LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
BLAS= -lf77blas
LAPACK= -lalapack -lcblas
.else
-LIB_DEPENDS+= blas:${PORTSDIR}/math/blas
-LIB_DEPENDS+= lapack:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas
+LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.endif
diff --git a/math/ocamlgsl/Makefile b/math/ocamlgsl/Makefile
index 9bbf513b8580..2d85d0c4da79 100644
--- a/math/ocamlgsl/Makefile
+++ b/math/ocamlgsl/Makefile
@@ -12,7 +12,7 @@ COMMENT= Interface to GSL for the Objective Caml language
LICENSE= GPLv3
-LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl
+LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk \
${OCAMLC_DEPEND}
RUN_DEPENDS= ocamlfind:${PORTSDIR}/devel/ocaml-findlib
diff --git a/math/octave-forge-dicom/Makefile b/math/octave-forge-dicom/Makefile
index fd4e2fd78016..ed19f062c303 100644
--- a/math/octave-forge-dicom/Makefile
+++ b/math/octave-forge-dicom/Makefile
@@ -12,7 +12,7 @@ COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
LICENSE= GPLv3
LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
-LIB_DEPENDS+= gdcmCommon:${PORTSDIR}/devel/gdcm
+LIB_DEPENDS+= libgdcmCommon.so:${PORTSDIR}/devel/gdcm
# OCTSRC is the name of the directory of the package.
# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
diff --git a/math/octave-forge-gsl/Makefile b/math/octave-forge-gsl/Makefile
index 7995e9c18c0d..3839aa444ae3 100644
--- a/math/octave-forge-gsl/Makefile
+++ b/math/octave-forge-gsl/Makefile
@@ -12,7 +12,7 @@ COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl
+LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
GNU_CONFIGURE= yes
CONFIGURE_ENV+= HOME=${WRKSRC}
diff --git a/math/octave-forge-ltfat/Makefile b/math/octave-forge-ltfat/Makefile
index 5db2a7d926cb..a5a2ab9e913e 100644
--- a/math/octave-forge-ltfat/Makefile
+++ b/math/octave-forge-ltfat/Makefile
@@ -11,9 +11,9 @@ COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
LICENSE= GPLv3
LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
-LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
- portaudio:${PORTSDIR}/audio/portaudio2 \
- cblas:${PORTSDIR}/math/cblas
+LIB_DEPENDS= libfftw3.so:${PORTSDIR}/math/fftw3 \
+ libportaudio.so:${PORTSDIR}/audio/portaudio2 \
+ libcblas.so:${PORTSDIR}/math/cblas
# OCTSRC is the name of the directory of the package.
# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
diff --git a/math/octave-forge-octproj/Makefile b/math/octave-forge-octproj/Makefile
index 96bf838d440d..2fb184d8fbcf 100644
--- a/math/octave-forge-octproj/Makefile
+++ b/math/octave-forge-octproj/Makefile
@@ -18,7 +18,7 @@ OCTSRC= ${OCTAVE_PKGNAME}
WRKSRC= ${WRKDIR}/${OCTSRC}/src
-LIB_DEPENDS+= proj:${PORTSDIR}/graphics/proj
+LIB_DEPENDS+= libproj.so:${PORTSDIR}/graphics/proj
.include "${.CURDIR}/../../Mk/bsd.octave.mk"
diff --git a/math/octave-forge-symbolic/Makefile b/math/octave-forge-symbolic/Makefile
index 509330bd94ee..d36b78e76993 100644
--- a/math/octave-forge-symbolic/Makefile
+++ b/math/octave-forge-symbolic/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
OCTSRC= ${OCTAVE_PKGNAME}
-LIB_DEPENDS+= ginac:${PORTSDIR}/math/GiNaC
+LIB_DEPENDS+= libginac.so:${PORTSDIR}/math/GiNaC
WRKSRC= ${WRKDIR}/${OCTSRC}/src
diff --git a/math/octave-forge-video/Makefile b/math/octave-forge-video/Makefile
index b85bf9576a66..f7a10c077c07 100644
--- a/math/octave-forge-video/Makefile
+++ b/math/octave-forge-video/Makefile
@@ -16,7 +16,7 @@ USES= pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV+= HOME=${WRKSRC}
-LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS+= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
.include "${.CURDIR}/../../Mk/bsd.octave.mk"
.include <bsd.port.mk>
diff --git a/math/orpie/Makefile b/math/orpie/Makefile
index 5b5f486e642b..e4d0e14135ea 100644
--- a/math/orpie/Makefile
+++ b/math/orpie/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Fullscreen RPN calculator for the console
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
-LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl
+LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
GNU_CONFIGURE= yes
USES= gmake
diff --git a/math/petsc/Makefile b/math/petsc/Makefile
index 3b20a79680ea..bdabfe20dc68 100644
--- a/math/petsc/Makefile
+++ b/math/petsc/Makefile
@@ -50,7 +50,7 @@ PLIST_SUB= PFX=${PFX} TARGET=${TARGET}
.if !defined(WITHOUT_UMFPACK)
UMFPACK_LIBS= umfpack.so,cholmod.so,colamd.so,amd.so,suitesparseconfig.so
L=${LOCALBASE}/lib/lib
-LIB_DEPENDS+= umfpack:${PORTSDIR}/math/suitesparse
+LIB_DEPENDS+= libumfpack.so:${PORTSDIR}/math/suitesparse
CONFIGURE_ARGS+= --with-umfpack-include="${LOCALBASE}/include/suitesparse" \
--with-umfpack-lib="[${UMFPACK_LIBS:C/^/${L}/:C/,/, ${L}/g}]"
.endif
diff --git a/math/ploticus/Makefile b/math/ploticus/Makefile
index e8f34ba3cddb..f5a56d9e79d0 100644
--- a/math/ploticus/Makefile
+++ b/math/ploticus/Makefile
@@ -11,10 +11,10 @@ DISTNAME= pl${PORTVERSION:S/.//}src
MAINTAINER?= linimon@FreeBSD.org
COMMENT?= Generates plots and graphs from data
-LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd \
- jpeg:${PORTSDIR}/graphics/jpeg \
- ming:${PORTSDIR}/graphics/ming \
- png15:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libming.so:${PORTSDIR}/graphics/ming \
+ libpng15.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2
BUILD_WRKSRC= ${WRKSRC}/src
diff --git a/math/py-gmpy/Makefile b/math/py-gmpy/Makefile
index 6e3557d9eaf2..7b88e934bef8 100644
--- a/math/py-gmpy/Makefile
+++ b/math/py-gmpy/Makefile
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= wen@FreeBSD.org
COMMENT= Python Extension that Wraps the GMP Library
-LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
USES= zip
USE_PYTHON= yes
diff --git a/math/py-gsl/Makefile b/math/py-gsl/Makefile
index f131e254cc90..2e8ae0646793 100644
--- a/math/py-gsl/Makefile
+++ b/math/py-gsl/Makefile
@@ -15,7 +15,7 @@ COMMENT= Python interface to GNU Scientific Library
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/core/include/numpy/arrayobject.h:${PORTSDIR}/math/py-numpy
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/__init__.py:${PORTSDIR}/math/py-numpy
-LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl
+LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/math/ruby-gsl/Makefile b/math/ruby-gsl/Makefile
index 15d834439ede..61112cda00ac 100644
--- a/math/ruby-gsl/Makefile
+++ b/math/ruby-gsl/Makefile
@@ -15,7 +15,7 @@ DIST_SUBDIR= ruby
MAINTAINER= clsung@FreeBSD.org
COMMENT= Ruby extension library for GSL (GNU Scientific Library)
-LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl
+LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
USE_RUBY= yes
USE_RUBY_SETUP= yes
diff --git a/math/scalapack/Makefile b/math/scalapack/Makefile
index 34f0b92b30ad..822bb6cf0028 100644
--- a/math/scalapack/Makefile
+++ b/math/scalapack/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= maho@FreeBSD.org
COMMENT= The ScaLAPACK Scalable LAPACK library
BUILD_DEPENDS= f2c:${PORTSDIR}/lang/f2c
-LIB_DEPENDS= blacs.1:${PORTSDIR}/math/blacs
+LIB_DEPENDS= libblacs.so:${PORTSDIR}/math/blacs
CONFLICTS= elmer-mathlibs-1*
@@ -43,12 +43,12 @@ NO_STAGE= yes
WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
-LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
BLAS= -lf77blas
LAPACK= -lalapack -lcblas
.else
-LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas
+LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.endif
diff --git a/math/sdpa-gmp/Makefile b/math/sdpa-gmp/Makefile
index 37f518ccfa70..927da7d4e2cf 100644
--- a/math/sdpa-gmp/Makefile
+++ b/math/sdpa-gmp/Makefile
@@ -22,9 +22,9 @@ MANUALVER= 7.1.1
SRCFILE= ${PORTNAME}.${PORTVERSION}.src.${SRCDATE}.tar.gz
MANUALFILE= sdpa.${MANUALVER}.manual.${MANDATE}.pdf
GNU_CONFIGURE= yes
-LIB_DEPENDS+= spooles:${PORTSDIR}/math/spooles \
- gmp.10:${PORTSDIR}/math/gmp \
- mpfr.4:${PORTSDIR}/math/mpfr
+LIB_DEPENDS+= libspooles.so:${PORTSDIR}/math/spooles \
+ libgmp.so:${PORTSDIR}/math/gmp \
+ libmpfr.so:${PORTSDIR}/math/mpfr
CONFIGURE_ARGS+= --with-system-spooles
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/spooles
diff --git a/math/sdpa/Makefile b/math/sdpa/Makefile
index 5151dd98201e..17577e934e1c 100644
--- a/math/sdpa/Makefile
+++ b/math/sdpa/Makefile
@@ -31,17 +31,17 @@ WITH_BLAS?= reference
.endif
. if ${WITH_BLAS} == reference
-LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas
+LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.elif ${WITH_BLAS} == gotoblas
-LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libgoto2.so:${PORTSDIR}/math/gotoblas
+LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
BLAS= -lgoto2p
LAPACK=
.elif ${WITH_BLAS} == atlas
-LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
BLAS= -lptf77blas
LAPACK= -lalapack -lptcblas
.endif
diff --git a/math/sdpara/Makefile b/math/sdpara/Makefile
index 012c6e7d0ef3..03102d5b854d 100644
--- a/math/sdpara/Makefile
+++ b/math/sdpara/Makefile
@@ -13,9 +13,9 @@ EXTRACT_ONLY= ${SRCFILE}
MAINTAINER= maho@FreeBSD.org
COMMENT= SDPARA parallel version of SDPA (math/sdpa)
-LIB_DEPENDS= scalapack:${PORTSDIR}/math/scalapack \
- blacs:${PORTSDIR}/math/blacs \
- mpich:${PORTSDIR}/net/mpich2
+LIB_DEPENDS= libscalapack.so:${PORTSDIR}/math/scalapack \
+ libblacs.so:${PORTSDIR}/math/blacs \
+ libmpich.so:${PORTSDIR}/net/mpich2
SRCDATE= 20090109
MANDATE= 20080618
@@ -34,16 +34,16 @@ WITH_BLAS?= reference
.endif
. if ${WITH_BLAS} == reference
-LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas
+LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.elif ${WITH_BLAS} == gotoblas
-LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
+LIB_DEPENDS+= libgoto2.so:${PORTSDIR}/math/gotoblas
BLAS= -lgoto2p
LAPACK= -lgoto2p
.elif ${WITH_BLAS} == atlas
-LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
BLAS= -lptf77blas
LAPACK= -lalapack -lptcblas
.endif
diff --git a/math/superlu/Makefile b/math/superlu/Makefile
index 86604c9e3a34..91f7bae8d1ce 100644
--- a/math/superlu/Makefile
+++ b/math/superlu/Makefile
@@ -31,13 +31,13 @@ WITH_BLAS?= reference
.endif
. if ${WITH_BLAS} == reference
-LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas
BLAS= -lblas
.elif ${WITH_BLAS} == gotoblas
-LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
+LIB_DEPENDS+= libgoto2.so:${PORTSDIR}/math/gotoblas
BLAS= -lgoto2p
.elif ${WITH_BLAS} == atlas
-LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
BLAS= -lptf77blas
.endif
diff --git a/math/timbl/Makefile b/math/timbl/Makefile
index 5e3fc18f40eb..5015178da544 100644
--- a/math/timbl/Makefile
+++ b/math/timbl/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= http://ilk.uvt.nl/downloads/pub/software/
MAINTAINER= yuri@tsoft.com
COMMENT= Tilburg Memory Based Learner
-LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
-
+LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2
GNU_CONFIGURE= yes
USES= gmake pathfix pkgconfig