aboutsummaryrefslogtreecommitdiff
path: root/misc/alevt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/alevt/Makefile')
-rw-r--r--misc/alevt/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/misc/alevt/Makefile b/misc/alevt/Makefile
index 5606de055c5e..01a8c576410e 100644
--- a/misc/alevt/Makefile
+++ b/misc/alevt/Makefile
@@ -14,9 +14,21 @@ MASTER_SITES= http://www.goron.de/~froese/alevt/
MAINTAINER= ports@FreeBSD.org
COMMENT= X11 Teletext decoding and display program. (reads from /dev/vbi)
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+OPTIONS= PNG "export pages as png image" on \
+ SMALLFONT "use a smaller and thiner font" off
USE_X_PREFIX= yes
MAN1= alevt.1x alevt-date.1 alevt-cap.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PNG)
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+MAKE_ARGS+= -DWITH_PNG
+.endif
+
+.if defined(WITH_SMALLFONT)
+MAKE_ARGS+= -DWITH_SMALLFONT
+.endif
+
+.include <bsd.port.post.mk>