aboutsummaryrefslogtreecommitdiff
path: root/misc/amanda25-server
diff options
context:
space:
mode:
Diffstat (limited to 'misc/amanda25-server')
-rw-r--r--misc/amanda25-server/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/misc/amanda25-server/Makefile b/misc/amanda25-server/Makefile
index ff8543765fe4..86057d5a9524 100644
--- a/misc/amanda25-server/Makefile
+++ b/misc/amanda25-server/Makefile
@@ -32,6 +32,8 @@ CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
USE_LDCONFIG= yes
WANT_PERL= yes
+SAMBA_PORT?= net/samba34
+
OPTIONS= GNUTAR "use GNU tar" on \
SSH "enable ssh-auth" off
@@ -139,8 +141,8 @@ PLIST_SUB+= PLOT='@comment '
.endif
.if defined (WITH_SAMBA)
-BUILD_DEPENDS+= smbclient:${PORTSDIR}/net/samba3
-RUN_DEPENDS+= smbclient:${PORTSDIR}/net/samba3
+BUILD_DEPENDS+= smbclient:${PORTSDIR}/${SAMBA_PORT}
+RUN_DEPENDS+= smbclient:${PORTSDIR}/${SAMBA_PORT}
CONFIGURE_ARGS+= --with-smbclient=${PREFIX}/bin/smbclient
.endif