aboutsummaryrefslogtreecommitdiff
path: root/misc/astrolog/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/astrolog/Makefile')
-rw-r--r--misc/astrolog/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/misc/astrolog/Makefile b/misc/astrolog/Makefile
index a1bccec2b295..5ba2dc70994d 100644
--- a/misc/astrolog/Makefile
+++ b/misc/astrolog/Makefile
@@ -33,18 +33,13 @@ DIST_SUBDIR= astrolog
ALL_TARGET= astrolog
NO_WRKSUBDIR= yes
-post-extract:
- -@${MKDIR} ${WRKDIR}/ephem
- ${UNZIP_CMD} -a -qo ${_DISTDIR}/${EPHEM} -d ${WRKDIR}/ephem
-
post-patch:
@${REINPLACE_CMD} -e "s@malloc.h@stdlib.h@g" \
${WRKSRC}/astrolog.h ${WRKSRC}/placalc.h
do-install:
-@${MKDIR} ${PREFIX}/lib/astrolog
- cd ${WRKDIR}/ephem && \
- ${INSTALL_DATA} * ${PREFIX}/lib/astrolog
+ ${UNZIP_CMD} -qao ${_DISTDIR}/${EPHEM} -d ${PREFIX}/lib/astrolog
cd ${WRKSRC}; \
${INSTALL_DATA} astrolog.dat ${PREFIX}/lib/astrolog/astrolog.dat-dist; \
if [ ! -f ${PREFIX}/lib/astrolog/astrolog.dat ] ; then \