aboutsummaryrefslogtreecommitdiff
path: root/misc/astrolog/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/astrolog/Makefile')
-rw-r--r--misc/astrolog/Makefile38
1 files changed, 15 insertions, 23 deletions
diff --git a/misc/astrolog/Makefile b/misc/astrolog/Makefile
index bf50ac3cf27b..3805c780855d 100644
--- a/misc/astrolog/Makefile
+++ b/misc/astrolog/Makefile
@@ -7,39 +7,31 @@
# Date created: 31 July 1995
# Whom: faulkner@cactus.org
#
-# $Id: Makefile,v 1.7 1997/01/13 22:56:39 ache Exp $
+# $Id: Makefile,v 1.8 1997/01/24 10:20:50 asami Exp $
#
-DISTNAME= ast53src
+DISTNAME= ast53unx
PKGNAME= astrolog-5.30
CATEGORIES= misc
-MASTER_SITES= http://rpkalf2.mach.uni-karlsruhe.de/~ferber/astrolog/
-DISTFILES= ${EXTRACT_ONLY} ast53dos.zip
+MASTER_SITES= http://www.astrolog.org/ftp/ephem/ \
+ http://www.astrolog.org/ftp/ \
+ ftp://ftp.relcom.ru/unix/magick/astrology/astrolog/
+EXTRACT_ONLY= ${DISTNAME}.shr
+EPHEM= LRZ5_24 CHI_24 CPJV_24
+DISTFILES= ${EXTRACT_ONLY} ${EPHEM}
MAINTAINER= ache@FreeBSD.ORG
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-
-EXTRACT_ONLY= ${DISTNAME}.zip
-EXTRACT_CMD= unzip
-EXTRACT_ARGS= -oqLaa
+EXTRACT_CMD= /bin/sh
+EXTRACT_ARGS=
DIST_SUBDIR= astrolog
-MAKEFILE= makefile.unx
ALL_TARGET= astrolog
NO_WRKSUBDIR= Yes
-EPHEM= LRZ5_24 CHI_24 CPJV_24
-MISC= helpfile.530 update.530
-
-post-extract:
- cd ${WRKSRC} && \
- unzip -oq ${DISTDIR}/${DIST_SUBDIR}/ast53dos.zip ${EPHEM}
- cd ${WRKSRC} && \
- unzip -oqLaa ${DISTDIR}/${DIST_SUBDIR}/ast53dos.zip ${MISC}
-
do-install:
-@${MKDIR} ${PREFIX}/lib/astrolog
- cd ${WRKSRC} && ${INSTALL_DATA} ${EPHEM} ${PREFIX}/lib/astrolog
+ cd ${DISTDIR}/${DIST_SUBDIR} && \
+ ${INSTALL_DATA} ${EPHEM} ${PREFIX}/lib/astrolog
cd ${WRKSRC} && \
if [ -f ${PREFIX}/lib/astrolog/astrolog.dat ] ; then \
${INSTALL_DATA} astrolog.dat ${PREFIX}/lib/astrolog/astrolog.dat-dist; \
@@ -49,11 +41,11 @@ do-install:
cd ${WRKSRC} && ${INSTALL_PROGRAM} astrolog ${PREFIX}/bin
-@${MKDIR} ${PREFIX}/share/doc/astrolog
cd ${WRKSRC} && \
- ${INSTALL_DATA} helpfile.530 ${PREFIX}/share/doc/astrolog/Helpfile.530
+ ${INSTALL_DATA} Helpfile.530 ${PREFIX}/share/doc/astrolog
cd ${WRKSRC} && \
- ${INSTALL_DATA} update.530 ${PREFIX}/share/doc/astrolog/Update.530
+ ${INSTALL_DATA} Update.530 ${PREFIX}/share/doc/astrolog
cd ${WRKSRC} && \
- ${INSTALL_DATA} readme.530 ${PREFIX}/share/doc/astrolog/Readme.530
+ ${INSTALL_DATA} README.530 ${PREFIX}/share/doc/astrolog
@echo
@echo "See the file ${PREFIX}/share/doc/astrolog/Helpfile.530 for help"
@echo "and tune ${PREFIX}/lib/astrolog/astrolog.dat"