aboutsummaryrefslogtreecommitdiff
path: root/misc/bb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/bb/Makefile')
-rw-r--r--misc/bb/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/misc/bb/Makefile b/misc/bb/Makefile
index dc537f394e06..edd76bd516ae 100644
--- a/misc/bb/Makefile
+++ b/misc/bb/Makefile
@@ -26,6 +26,12 @@ PORTDOCS= README
PLIST_FILES= bin/bb share/bb/bb.s3m share/bb/bb2.s3m share/bb/bb3.s3m
PLIST_DIRS= share/bb
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
pre-patch:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -E -e "s@#include +<malloc.h>@#include <stdlib.h>@g"
@@ -35,4 +41,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>