aboutsummaryrefslogtreecommitdiff
path: root/misc/bookcase/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/bookcase/Makefile')
-rw-r--r--misc/bookcase/Makefile19
1 files changed, 17 insertions, 2 deletions
diff --git a/misc/bookcase/Makefile b/misc/bookcase/Makefile
index 7abb227a31fb..18d43b419bc1 100644
--- a/misc/bookcase/Makefile
+++ b/misc/bookcase/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= bookcase
-PORTVERSION= 0.7.2
-PORTREVISION= 1
+PORTVERSION= 0.8.3
CATEGORIES= misc kde
MASTER_SITES= http://www.periapsis.org/bookcase/download/
@@ -16,7 +15,23 @@ COMMENT= Personal book collection manager for KDE
USE_KDELIBS_VER=3
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|strings.h|bc_strings.h|g' \
+ ${WRKSRC}/src/Makefile.in \
+ ${WRKSRC}/src/filehandler.cpp \
+ ${WRKSRC}/src/translators/bibtexmlimporter.cpp \
+ ${WRKSRC}/src/translators/bookcaseimporter.cpp
+ @${MV} ${WRKSRC}/src/strings.h ${WRKSRC}/src/bc_strings.h
+ @${TOUCH} ${WRKSRC}/config.h.in
.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+CFLAGS+= -D__LIBSTDCPP_PARTIAL_SUPPORT__
+.endif
+
.include "${PORTSDIR}/x11/kde3/Makefile.kde"
.include <bsd.port.post.mk>