aboutsummaryrefslogtreecommitdiff
path: root/misc/boxes/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/boxes/Makefile')
-rw-r--r--misc/boxes/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/misc/boxes/Makefile b/misc/boxes/Makefile
index a7a71aade035..9618d791ae4e 100644
--- a/misc/boxes/Makefile
+++ b/misc/boxes/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= boxes
-PORTVERSION= 1.0
+PORTVERSION= 1.0.1
CATEGORIES= misc
MASTER_SITES= http://www6.informatik.uni-erlangen.de/~tsjensen/software/boxes/download/ \
${MASTER_SITE_SUNSITE}
@@ -18,7 +18,13 @@ MAINTAINER= patseal@hyperhost.net
MAN1= boxes.1
USE_GMAKE= yes
USE_BISON= yes
-ALL_TARGET=
+ALL_TARGET= boxes
+MAKE_ARGS= GLOBALCONF=${GLOBALCONF} CFLAGS_ADDTL="${CFLAGS}"
+
+GLOBALCONF= ${PREFIX}/share/boxes/boxes-config
+
+do-patch:
+ ${TOUCH} ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/boxes ${PREFIX}/bin