aboutsummaryrefslogtreecommitdiff
path: root/misc/brs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/brs/Makefile')
-rw-r--r--misc/brs/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/misc/brs/Makefile b/misc/brs/Makefile
index 88fabfa3a7bd..e6eb71bac60d 100644
--- a/misc/brs/Makefile
+++ b/misc/brs/Makefile
@@ -6,17 +6,26 @@
#
PORTNAME= brs
-PORTVERSION= 4.0
+PORTVERSION= 4.03
CATEGORIES= misc
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= apps/religion
-DISTNAME= brs.4.00.l1
+MASTER_SITES= ftp://classworld.com/BRS/ \
+ http://www.unknown.nu/ports/
+DISTFILES= bible.data.tar bible.tar.Z
+DIST_SUBDIR= brs
MAINTAINER= user@unknown.nu
COMMENT= An interactive King James Bible
-WRKSRC= ${WRKDIR}/bible
+NO_WRKSUBDIR= yes
ALL_TARGET=
MAN1= bible.1
+post-patch:
+ @${MV} ${WRKSRC}/brl.c ${WRKSRC}/brl.c.sed
+ ${SED} -e "s=%%PREFIX%%=${PREFIX}=g" \
+ ${WRKSRC}/brl.c.sed > ${WRKSRC}/brl.c
+ @${MV} ${WRKSRC}/bible.1 ${WRKSRC}/bible.1.sed
+ ${SED} -e "s=%%PREFIX%%=${PREFIX}=g" \
+ ${WRKSRC}/bible.1.sed > ${WRKSRC}/bible.1
+
.include <bsd.port.mk>