aboutsummaryrefslogtreecommitdiff
path: root/misc/compat5x/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/compat5x/Makefile')
-rw-r--r--misc/compat5x/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/misc/compat5x/Makefile b/misc/compat5x/Makefile
index 335d7f37a363..9c20b0ca6bca 100644
--- a/misc/compat5x/Makefile
+++ b/misc/compat5x/Makefile
@@ -11,7 +11,7 @@
PORTNAME= compat5x
PORTVERSION= 5.4.0.8
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR=lesi/compat5x
@@ -69,14 +69,14 @@ do-install:
@${MKDIR} ${TARGET_DIR}
.if ${OSVERSION} >= 800105
${RM} -f ${WRKSRC}/libpthread.so.1
- (cd ${TARGET_DIR} && ${LN} -s /usr/lib/libpthr.so ./libpthread.so.1)
+ (cd ${TARGET_DIR} && ${LN} -sf libthr.so.1 libpthread.so.1)
.endif
(cd ${WRKSRC} && ${INSTALL_DATA} *.so.* ${TARGET_DIR})
.if ${ARCH} == amd64
@${MKDIR} ${TARGET32_DIR}
. if ${OSVERSION} >= 800105
${RM} -f ${WRKSRC}/lib32/libpthread.so.1
- (cd ${TARGET32_DIR} && ${LN} -s /usr/lib32/libpthr.so ./libpthread.so.1)
+ (cd ${TARGET32_DIR} && ${LN} -sf libthr.so.1 libpthread.so.1)
. endif
(cd ${WRKSRC}/lib32 && ${INSTALL_DATA} *.so.* ${TARGET32_DIR})
.endif