aboutsummaryrefslogtreecommitdiff
path: root/misc/dahdi-kmod/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/dahdi-kmod/Makefile')
-rw-r--r--misc/dahdi-kmod/Makefile21
1 files changed, 18 insertions, 3 deletions
diff --git a/misc/dahdi-kmod/Makefile b/misc/dahdi-kmod/Makefile
index 336e405c5532..f4541128e651 100644
--- a/misc/dahdi-kmod/Makefile
+++ b/misc/dahdi-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dahdi
PORTVERSION= ${DAHDI_VERSION:S/-//g}
-PORTREVISION= 4
+PORTREVISION= 0
CATEGORIES= misc kld
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= fjoe
@@ -19,8 +19,8 @@ COMMENT= Digium/Asterisk Hardware Device Interface
BUILD_DEPENDS= gmake:${PORTSDIR}/devel/gmake
LIB_DEPENDS= newt.52:${PORTSDIR}/devel/newt
-DAHDI_VERSION= 2.2.1-rc2
-DAHDI_TOOLS_VERSION= 2.2.1.1-rc1
+DAHDI_VERSION= 2.3.0-rc2
+DAHDI_TOOLS_VERSION= 2.3.0
NO_PACKAGE= Should be in sync with the kernel to work correctly
GNU_CONFIGURE= yes
@@ -39,8 +39,23 @@ MAN8= dahdi_cfg.8\
dahdi_tool.8\
fxotune.8
+OPTIONS= EXPERIMENTAL "Enable experimental drivers" off
+
.include <bsd.port.pre.mk>
+.if ${ARCH} == "i386" || ${ARCH} == "amd64"
+PLIST_SUB+= X86=""
+.else
+PLIST_SUB+= X86="@comment "
+.endif
+
+.if defined(WITH_EXPERIMENTAL)
+MAKE_FLAGS+= WITH_EXPERIMENTAL=yes
+PLIST_SUB+= WITH_EXPERIMENTAL=""
+.else
+PLIST_SUB+= WITH_EXPERIMENTAL="@comment "
+.endif
+
pre-everything::
@if [ ! -f /usr/src/sys/Makefile ]; then \
${ECHO_MSG} ">> The dahdi port needs FreeBSD kernel source code to compile."; \