aboutsummaryrefslogtreecommitdiff
path: root/misc/floatator/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/floatator/Makefile')
-rw-r--r--misc/floatator/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/misc/floatator/Makefile b/misc/floatator/Makefile
index cbf196a44b1b..8b6f90e9bced 100644
--- a/misc/floatator/Makefile
+++ b/misc/floatator/Makefile
@@ -14,17 +14,15 @@ MASTER_SITES= http://floatator.cichon.com/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= An interactive fluid dynamics simulation
-USE_REINPLACE= yes
-USE_XLIB= yes
-USE_MOTIF= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-post-patch:
- @${REINPLACE_CMD} -e "s,^CC,#CC,g ; s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
+USE_MOTIF= yes
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DNDEBUG" \
+ X11INCLUDE="-I${X11BASE}/include" X11LIB="-L${X11BASE}/lib"
do-install:
.for f in floatator floatator_X_interface
- ${INSTALL_PROGRAM} ${WRKSRC}/$f ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
.endfor
.include <bsd.port.mk>